Problem
The DLO (Desktop and Laptop Option) client repeatedly prompts for credentials and does not seem to accept them. After they are entered the dialog window closes.
Error Message
A DLO debug log may show FAILED ASSERTION: common\foundation_ace\osys\xplat.cpp ( line: 295 ).
Cause
This can happen if the DLO UserShare registry key is pointing to the wrong path.
Solution
Correct the registry value as follows:
Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
1. Open regedit or regedt32
2. Browse to the HKCU\Software\Symantec\DLO\3.0\Client\UserShare key
3. Delete the /UserShare key
4. Reopen the DLO Client