After successful installation and registration of the NetBackup plug-in, it does not appear in the vSphere Web Client GUI.

Article: 100023969
Last Published: 2018-03-27
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

After following the installation steps in the NetBackup Web Client Plug-in Guide, the plug-in does not appear in the vSphere Web Client.

Error Message

No error messages is reported but the Plug-in does not show after logging in to the vSphere Web Client.

Cause

The Plug-in files are not downloaded correctly from plug-in package host.

Solution

After registering the plug-in, please check the following folder on the vSphere Web Client Server - or if the web client is installed on the vCenter, check the folder on the Windows vCenter server:

%ProgramData%\VMwarevSphere Web Client\vc-packages\vsphere-client-serenity\

This folder needs to contain a folder having the name in the format: com.Veritas.netbackup.plugin-<version> (which is to say, for example, com.Veritas.netbackup.plugin-7.6.1 for NetBackup 7.6.1 or com.Veritas.netbackup.plugin-7.6.1.1 for 7.6.1.1).  If this folder does not exist, create it and unzip netbackup-vwc-plugin.zip into it.

Example screenshot for 7.6.1.1:

NetBackup Plug-in for vSphere - 01

For NetBackup 8.0: After registering the plug-in, please check the following folder on the vSphere Web Client Server, or if the web client is installed on the vCenter, check the folder on the Windows vCenter server:

\ProgramData\VMware\vCenterServer\cfg\vsphere-client\vc-packages\vsphere-client-serenity\

This folder needs to contain a folder having the name in the format: com.symantec.netbackup.plugin-<version>. If this folder does not exist, create it and unzip netbackup-vwc-plugin.zip into it.

Name of the folder to create at the above path: com.symantec.netbackup.plugin-8.0

Once this is done, log out of the Web Client and log back in.

Example screenshot showing the plug-in appearing in the vSphere Web Client GUI:

 

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