Unable to deploy Enterprise Vault mail-app using the New-App -URL parameter after the installation of Microsoft Exchange 2013 CU9.
Problem
After installation of Microsoft Exchange 2013 CU9, the deployment of the Enterprise Vault Office Mail App may fail with the error:"The app couldn't be downloaded."
Error Message
The cmdlets to deploy the Office Mail App are as follows.User-level mail app deployment:
New-App -mailbox $Mbx.LegacyExchangeDN -Url("http://EVServer/EnterpriseVault/OfficeMailAppManifest.aspx?LegacyMbxDn="+$Mbx.LegacyExchangeDN)
Organization-wide deployment:
New-App -OrganizationApp -DefaultStateForUser:enabled -Url ("http://EVServer/EnterpriseVault/OfficeMailAppManifest.aspx?LegacyMbxDn="; +$Mbx.LegacyExchangeDN)
Both cmdlets fail with the error below when run against Exchange 2013 CU9:
The app couldn't be downloaded.
+ CategoryInfo : InvalidData: (:) [New-App], LocalizedException
+ FullyQualifiedErrorId : [Server=EX2013DB,RequestId=425e1039-8c64-4cce-8898-5a9ef69562d6,TimeStamp=MM/DD/YYYY [FailureCategory=Cmdlet-LocalizedException]
D65158A2,Microsoft.Exchange.Management.Extension.NewApp
+ PSComputerName : CAS.Domain.local
Cause
This is due to restrictions Microsoft has introduced in Exchange 2013 CU9 with regard to the use of the New-App cmdlet with the -Url parameter.Solution
Workaround:
The Mail App can be installed using the more complicated example given in the troubleshooting section of the Setting Up Exchange Server Archiving guide. These steps will first download the manifest data into the PowerShell session and then deploy the App using the downloaded manifest.
Note: Each numbered step should be entered as a single command in the Exchange Management Shell, or they can be combined into a script to run repeatedly. The first step is the only one that requires modification (substitute the name of the mailbox for which you want to deploy the EV Office Mail App).
1) $Mbx = get-mailbox "NameOfMailbox"
2) $uri = new-object system.uri("https://evserver/EnterpriseVault/OfficeMailAppManifest.aspx?LegacyMbxDn=" + $Mbx.LegacyExchangeDN)
3) $webclient = New-Object Net.Webclient
4) $webClient.UseDefaultCredentials = $true
5) try {$bytes = $webclient.DownloadData($uri); New-App -mailbox $Mbx.LegacyExchangeDN -FileData $bytes;} catch [Net.WebException] {[Net.HttpWebResponse] $webResponse = [Net.HttpWebResponse]$_.Exception.Response; Write-Warning $webResponse.StatusDescription;}
Veritas has acknowledged that the above-mentioned issue is present in the version(s) of the product(s) referenced in this article.
This issue is currently under investigation by Veritas. Pending the outcome of the investigation, this issue may be resolved by way of a cumulative hotfix or service pack in the current or future versions of the software. However, this particular issue is not currently scheduled for any release. If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns. For information on how to contact Veritas Sales, please see https://www.Veritas.com .
Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.