Problem
The Veritas Enterprise Vault Event logs are full of 13360, 8453 and 8390 errors being generated at random intervals.
Error Message
Type : Error
Event : 8390
Source : Enterprise Vault
Category : Migrator Server
Description: The EnterpriseVault.DirectoryConnection object reported an error.
0x80040e14
Internal references:
Error [0x80040e14]
{CDirectoryConnectionObject::GetArchiveOrArchiveFolderSecurity}
V-437-8390
Type : Error
Event : 8453
Source : Enterprise Vault
Category : Directory Service
Description: The EnterpriseVault.DirectoryService object reported an error.
The error code was 0x80040e14
V-437-8453
Type : Error
Event : 13360
Source : Enterprise Vault
Category : Directory Service
Description: An error was detected while accessing the Vault Database 'EnterpriseVaultDirectory' (Internal reference: {CADODataAccess::ExecuteSQLCommand}
Description: he [Root] table is inconsistent for VaultEntryId 1E063D5C7B6C48B43A38438E7A2641BA51110000SVWCCG051.TEST.LOCAL
SQL Command: GetObjectSecurity
Additional Microsoft supplied information:
Source: Microsoft OLE DB Provider for SQL Server
Number: 0x80040e14
SQL State: 42000
Native Error: 00050000
HRESULT 0x80040e14
V-437-13360
Cause
The Stored Procedure being run is designed to check user permission access of an archive and folders. The SQL error being generated 0x80040e14 indicates that the query is failing to return any results as one of the parameters is not found. The Stored procedure is executed anytime a user tries to access an archived item.
One common cause of this error frenzy is when the archive in question has been deleted and Vault Cache still exists on the user's workstation. Consequently, when a user attempts to access items or synchronize, the stored procedure GetObjectSecurity is executed and the original Archive ID could not be found in the EnterpriseVaultDirectory.dbo.Root table.
An archive deletion can be confirmed by Event ID 6652 under the Storage Delete category.
Solution
- Verify that the VaultEntryID showing in Event ID 13360 does not exist by running the query below:a
Use EnterpriseVaultDirectory
Select * from Root where VaultEntryID = 'id from event'
- If it is not in the database, open the most recent IIS Log and perform a find for the VaultEntryID. This will show the user in question.
- The first course of action is to delete the Vault Cache and synchronize. If this completes successfully and the errors stop, the issue is resolved. The user may also have Orphaned shortcuts in the mailbox that need to be removed. This can be done by enabling the Delete Orphaned Shortcut option in the Mailbox Policy. If the errors continue, continue to Step 4.
- If the same issue occurs do the following:
a. Disable the user from archiving and Export the archive to PST
b. Mount the PST and verify it contains all items with the proper folder structure
c. Delete the original archive
d. Re-enable the user to create the new archive
e. Import the PST to the new archive