Unable to import Veritas NetBackup Tape Media

Article: 100023351
Last Published: 2009-01-27
Ratings: 0 0
Product(s): NetBackup

Problem

During the import, the import log will indicate the failure to mount media: "Status = error requesting media (tpreq)."

The Activity Monitor will show that the import job failed with a Status 98.

Error Message

Status = error requesting media (tpreq).

Cause

In this example, the previous request was initiated by a second import job.

Troubleshooting:

  • Check the Device Monitor for any previous Pending Requests of that Media ID.
  • Check the Activity Monitor for the active job that has posted the original request.

The NetBackup Data Center Media Manager System Administrator's Guide defines tpreq as:

  • "tpreq - request a tape volume for mounting and associate a file name with the assigned drive."

The file name that is created is located in the following directory:

install_path\Veritas\NetBackup\db\media\tpreq\MediaID

Note: If a previous media request (backup, restore or import) has requested the media and the media is not mounted, any additional requests for that media are denied. This is expected behavior and is most often observed with Stand Alone Tape Devices.

The import log states the error:
Status = error requesting media (tpreq).

Examination of the error is revealed in the bptm log file.
TpErrno = File name already exists.

Example, import log snippet:
C:\Program Files\Veritas\NetBackup\logs\nbimport\import1-0001.log
Import phase 1 started Wed May 21 2003 14:13:38
14:13:38 INF - Create DB information for media id NBU100.
14:13:38 INF - Initiation of bptm process to read media id NBU100 was successful.
14:13:38 INF - Waiting for mount of media id NBU100on server nbu2001.
14:13:39 INF - Status = error requesting media(tpreq).


Example, bptm log snippet:
C:\Program Files\Veritas\NetBackup\logs\bptm\052103.log
14:13:39.109[1516.2128] <16> mount_open_media: error requesting media, TpErrno = Filename already exists
14:13:39.109 [1516.2128] <2> bptm: EXITING with status 98 <----------

Solution

1. Mount the media and fulfill the original mount request. The original job will continue.
2. Deny the mount and reinitialize the job (backup, restore or import).

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