Problem
Experiencing slow performance during backups, archives, or restores.
Error Message
N/A: Slow Performance
Cause
Potential network issues.
Solution
When experiencing slow performance with NetBackup (NBU), especially to a single client (or group of clients), the first thing to do is verify the throughput of the network between the master server and the client or group of clients. By removing NBU from the equation, it can be determined if the network is the problem.
To accomplish this, transfer a file from the media server to the client. Then, transfer the file from the client back to the media server. It is recommended that the file be no less then 1G in size to ensure that the transfer rate is an accurate average of the throughput. If the transfer throughput is also slow, this is an indication that there are network issues to look into.
Note: There are a variety of things that can cause a slow network.
Some things to check are:
- Make sure that the network card settings match the network environment (for example, 100 Mbps vs 1000Mbps / Full duplex vs Half Duplex)
- Some back-end equipment (switches, routers, etc...) require auto-sense / auto-negotiate to be turned OFF - some require it ON.
- In the case of machines with multiple interfaces, check that the correct interface is being used by NBU.
Possible methods to track speed on a file transfer test:
- Robocopy can provide transfer speed metrics
- Example:
From the Client, logged in with the proper credentials: (format = robocopy <from dir> <to dir> /V)
robocopy C:\sourcedata \\<mediaserver>\C$\temp /V
- Example:
- FTP can provide transfer speed metrics
- Simply note the time at the start and end of the file transfer