Please enter search query.
Search <product_name> all support & community content...
Article: 100022495
Last Published: 2014-10-13
Ratings: 1 1
Product(s): Enterprise Vault
Problem
Event ID: 2778, and Event ID: 2779 are generated when archiving, restoring, or retrieving items.
Error Message
Event ID: 2779
Category: AgentClientBroker
Description: Failed to obtain Format Name of queue ".\private$\Enterprise Vault Exchange Mailbox Task for SERVER 100107113530 Admin Queue"
V-437-2779
Event ID: 2778
Category: AgentClientBroker
Description: The error c00e0003 occurred whilst calling the method CArchivingAgentQueue::RestoreItem()
V-437-2778
Cause
- Improper removal or change of an Exchange server targeted by Enterprise Vault (EV) for mailbox archiving
- Malformed Message Queues
Solution
Note: Prior to performing the steps below, confirm that there is a successful full database backup of EnterpriseVaultDirectory.
1. Stop the Enterprise Vault Admin Service on the Server in question.
2. Purge, and delete all Enterprise Vault message queues.
Note: Queues may be deleted at any time if the services are stopped and no objects are currently in the queue. For further instructions on " How to purge Microsoft Message Queues (MSMQ) used by Enterprise Vault," contact support.
3. Open the SQL Enterprise Manager.
4. Run the following SQL Query.
Note: On each line "WHERE ComputerNameAlternate in ('SERVERNAME'))", replace SERVERNAME with the ComputerNameAlternate name of the server in question.
Note: On each line "WHERE ComputerNameAlternate in ('SERVERNAME'))", replace SERVERNAME with the ComputerNameAlternate name of the server in question.
USE ENTERPRISEVAULTDIRECTORY
UPDATE StorageServiceEntry
SET StorageArchive = '', StorageRestore = '', StorageReplayIndex = '', StorageSpool = ''
WHERE ComputerEntryID in
(SELECT ComputerEntryID FROM ComputerEntry
WHERE ComputerNameAlternate in ('SERVERNAME'))
UPDATE RetrievalTask
SET RetrievalSpoolQueue = ''
WHERE TaskEntryID in (SELECT RT.TaskEntryID from retrievaltask RT
INNER JOIN Task T ON T.TaskEntryID = RT.TaskEntryID
INNER JOIN ComputerEntry CE ON CE.ComputerEntryID = T.ComputerEntryID
WHERE ComputerNameAlternate in ('SERVERNAME'))
UPDATE RetrievalTask
SET MessageQueue = ''
WHERE TaskEntryID in (SELECT RT.TaskEntryID from retrievaltask RT
INNER JOIN Task T ON T.TaskEntryID = RT.TaskEntryID
INNER JOIN ComputerEntry CE ON CE.ComputerEntryID = T.ComputerEntryID
WHERE ComputerNameAlternate in ('SERVERNAME'))
UPDATE ArchivingRetrievalTask
SET MessageQueue = ''
WHERE TaskEntryID in (SELECT ART.TaskEntryID from ArchivingRetrievalTask ART
INNER JOIN Task T ON T.TaskEntryID = ART.TaskEntryID
INNER JOIN ComputerEntry CE ON CE.ComputerEntryID = T.ComputerEntryID
WHERE ComputerNameAlternate in ('SERVERNAME'))
UPDATE JournalTask
SET MessageQueue = ''
WHERE TaskEntryID in (SELECT JT.TaskEntryID from JournalTask JT
INNER JOIN Task T ON T.TaskEntryID = JT.TaskEntryID
INNER JOIN ComputerEntry CE ON CE.ComputerEntryID = T.ComputerEntryID
WHERE ComputerNameAlternate in ('SERVERNAME'))
UPDATE PublicFolderTask
SET MessageQueue = ''
WHERE TaskEntryID in (SELECT PFT.TaskEntryID from PublicFolderTask PFT
INNER JOIN Task T ON T.TaskEntryID = PFT.TaskEntryID
INNER JOIN ComputerEntry CE ON CE.ComputerEntryID = T.ComputerEntryID
WHERE ComputerNameAlternate in ('SERVERNAME'))
5. Start the Enterprise Vault (EV) Services and confirm that the Message Queues are recreated.
6. Test archiving, restoring, and retrieval of archived items.
7. Verify that Event ID: 2778, and Event ID: 2779 do not resurface.