Discovery Accelerator Analytics fails referencing full-text search is not installed or enabled

Article: 100022242
Last Published: 2020-01-16
Ratings: 0 0
Product(s): Enterprise Vault

Problem

Attempting to enable Analytics for a Case in Enterprise Vault (EV) Discovery Accelerator (DA) fails with errors advising full-text search is either not installed or not enabled.

 

Error Message

SQL Server versions after 2008:

Full-Text Search is not enabled, or a full-text component cannot be loaded.

SQL Server versions before 2008:

Full-Text Search is not enabled for the current database. Use sp_fulltext_database to enable full-text search for the database.

 

Cause

To enable a DA case for Analytics, a valid DA License must be installed on the DA server and the SQL Full-text Filter Daemon Launcher Service must be installed and started on the SQL server. If either of these conditions are missing, attempting to enable DA Analytics will fail.

 

Solution

The following steps should be completed with the Enterprise Vault Accelerator Manager Service (EVAMS) stopped on the DA Server to prevent any updates during the process, but stopping the Service is not mandatory.

1. Confirm a valid DA license is installed:

1.1. Use Windows Explorer on the DA server and navigate to the license location, typically under \Program Files (x86)\Enterprise Vault Business Accelerator\Installed Licenses\.

1.2. Open the license file in Notepad and review the following sections:

<product_name>: This will list the version. Verify the version matches the installed version of DA.

<name>EVDA</name>: This is the license for the DA component.

<end_date>YYYY-MM-DD</end_date>: This is directly under the DA component and lists the component's expiration date.

1.3. If any of these 3 components do not match, are missing or have expired, please obtain a new license via the customer portal and upload it via the EVBAAdmin administration website using the Upload License option.

2. Confirm the SQL full-text indexing component is installed:

2.1. Log onto the SQL Server with an account having appropriate permissions (the Vault Service Account should have such permissions).

2.2. Open the Services management console and navigate to the SQL services. Determine if the SQL Full-text Filter Daemon Launcher service is installed. If this service is not installed, run the SQL Server installation program and add it, ensuring it is set to Automatic startup and is started.

Note: A prompt for adding features to an existing instance must be displayed. If such a prompt is not displayed, another version of SQL Server may be in use and not the installed version on the Server. Do not continue if the prompt for adding features to an existing instance is not displayed, otherwise a new SQL instance on the same server may be created.

2.3. Once the service listed above is installed, open Microsoft SQL Server Management Studio, click on New Query and execute the following query:

USE master;
SELECT name, is_fulltext_enabled
FROM sys.Databases
ORDER BY name;

2.4. Find the DA Customer database name in the name column and note the value of its corresponding entry in the is_fulltext_enabled column:

0 = full-text indexing is not enabled for the database.
1 = full-text indexing is enabled for the database.

2.5. If full-text indexing has not been enabled for the database, open a new Query window focused on the DA Customer database, enter the following lines in the Query window, replacing DACustomerDatabaseName with the name of the DA Customer Database and execute the query:

USE DACustomerDatabaseName;
EXEC sp_fulltext_Database enable;

Then verify the new setting by re-running the query in step 2.3 above.

2.6. Once verified, backup the database and transaction log.

2.7. Enable Analytics for the Case from within the DA Client.

If these steps do not resolve the errors listed above, please contact technical support for further assistance.

 

 

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