Accelerator Export to PST fails to move MSG files and logs Event ID 236 System.Runtime.InteropServices.COMException (0x8004011B)"

Article: 100021934
Last Published: 2024-07-08
Ratings: 1 0
Product(s): Enterprise Vault

Problem

Exporting to PST file fails to move one or more MSG files in to PST files with Event ID: 236 System.Runtime.InteropServices.COMException (0x8004011B) using Enterprise Vault (EV) Compliance Accelerator (CA) or Discovery Accelerator (DA).

 

Error Message

Source:      Accelerator Service Processor
Category:    None
Event ID:    236
Event Type:  Error
Description:
APP AT - Customer ID: 1 - (ExportPST) - Error moving MSG to PST for run 'DA Export' Number moved: 0.
System.Runtime.InteropServices.COMException (0x8004011B):
Exception from HRESULT: 0x8004011B
 at KVS.EnterpriseVaultInterop.PSTProviderClass.AddMsgToPST (String bsMsgFileName, String TargetFolderPath, String CustomPropName String CustomPropValue, Int32 bRemoveCustomProps
 at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.H...


 

Cause

When exporting items from the Enterprise Vault (EV) Compliance Accelerator (CA) or Discovery Accelerator (DA) products, one of the options is to export to PST files.  This export process actually exports the messages to their original message type files on the EV Storage Service server, moves the files to the Accelerator export folder, then uses Microsoft Outlook installed on the Accelerator server to move the files into PST files.  An option is present to convert EML formatted message files into MSG formatted message files as part of the export to PST processing.  If an exported MSG file is corrupt, the Accelerator export operation will fail to move the MSG file into a PST file and throw the Event 236 error.

The MSG file(s) that fail to move into PST files will be located in a Failed Items folder within the export folder structure.  For example, D:\Discovery Accelerator Export\EVBADiscovery\DA Export\Failed Items\Exchange\XXXX , where XXXX are the first 4 numbers of the ItemID for the failed to export item(s).  Double clicking on the MSG file(s) may fail to open Outlook with the error Cannot start Microsoft Outlook.
 

Solution

Due to the exported MSG file corruption, a workaround may exist to export the failed item(s) individually in HTML format.  Selecting the option to include attachments will cause the HTML rendering of the message to also include the HTML rendering of any attachments under the body of the message in the resulting HTML file.

 

 

 

References

UMI : V-437-236 Etrack : 236

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