RTF formatted email may display the background HTML in the shortcut body

Article: 100020756
Last Published: 2026-01-12
Ratings: 0 0
Product(s): Enterprise Vault

Problem

When encountering an Rich Text Formatting (RTF) formatted email that is malformed, it is possible that Enterprise Vault will post process the item so that its preview displays the underlying HTML that normally would be rendered by outlook.

Example:
 

Cause

The reason for the item being formatted in this manner is due to several RTF properties within the content of an email where the RTF elements are malformed and not properly being initialized.

Example of an invalid RTF:
\fromhtml1{
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>

Example of valid RTF:
{\rtf1\ansi\ansicpg65001\fromhtml1 \deff0{\fonttbl{\f0\fswiss Arial;}
{\f1\fswiss\fcharset0 Arial;}}
{\*\htmltag0 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3c.org/TR/1999/REC-html401-19991224/loose.dtd"><HTML><HEAD>


When Enterprise Vault encounters the malformed RTF it treats it as pure text instead, and thus the contents of the shortcut displays the background HTML.

 

Solution


As a workaround, you can do the following:

Using MFCMAPI (See Microsoft Article 906557 for additional information)
1. Restore the shortcut to an email
2. Use MFCMAPI.exe to edit either the PR_HTML or PR_RTF_COMPRESSED properties and once saved, Outlook will correct the inconsistencies
3. Re-Archive the email, once its post processing has complete you will have a fixed shortcut

NOTE: Performing the workaround will change the physical properties of the file, and once re-archived will be treated as a new item as its contents have changed

Although there is a known workaround, it is recommended that the vendor creating the malformed RTF should be contacted so that they can create a good and valid RTF.

 

Veritas Corporation has acknowledged that the above-mentioned issue is present in the version(s) of the product(s) referenced in this article. 

There are currently no plans to address this issue by way of a cumulative hotfix or service pack in the current or previous versions of the software at the present time. This issue may be resolved in a future major revision of the software at a later time, but is not scheduled for any release. If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns.  For information on how to contact Veritas Sales, please see https://www.veritas.com
 

 

References

Etrack : 1600927

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