Important Update: Cohesity Products Knowledge Base Articles


All Cohesity Knowledge Base Articles are now managed via the Cohesity Support Portal: https://support.cohesity.com/s/searchunify. The Knowledge Base articles available here will not reflect the latest information or may no longer be accessible.

Event ID 6643 when attempting to delete an Archive which is stored on a NetApp filer device

Article: 100020466
Last Published: 2021-09-03
Ratings: 0 0
Product(s): Enterprise Vault

Problem

Event ID 6643 may occur when attempting to delete an archive with items stored on a NetApp filer device, if the Vault Service Account does not have required permissions to delete.

Error Message

Event Type: Error
Event Source: Enterprise Vault
Event Category: Storage Delete
Event ID: 6643
Date: <Date>
Time: <Time>
User: N/A
Computer: <EVServerName>
Description:
Delete Vault failed
Reason: Access is denied.  [0x80070005]
Vault Name: <Archive Name>
Vault Store: <VaultStoreName>
Vault Id: <ArchiveVaultID Ex.12BFDFB900038FE4DAEB09E2CC0E8F88B1110000evsite>

NOTE: The archive name will show as a Red X in the Vault Admin Console with a status of "marked for deletion".

Cause

The above error can occur when the vault service account (VSA) lacks permissions on the NetApp device.

Solution

1. Add the VSA to the Local Administrators group on the NetApp, or at minimum on the vault store locations.  
   Ie. \\netapp\vaultstores
 
2. Follow article 000032288 under Related Articles to change the Status of the archive back to Available.
 
3. Attempt to delete the archive again.  This process may take sometime depending on the size of the archive
Note: If there are items on hold, via Compliancy Accelerator, the archive will not complete the deletion.
 

 

Was this content helpful?