Event Id's 3250 and 2216 are returned when trying to archive items from a mailbox.

Article: 100018328
Last Published: 2021-08-13
Ratings: 1 0
Product(s): Enterprise Vault

Problem

These events can occur when attempting to archive a mailbox that contains a corrupted message(s).  The Event ID 3250 will be seen indicating the title of the message that is causing the error.  The 2216 error will indicate the archiving process will suspend for 5 minutes due to a recoverable error. 
 

Error Message

Type: Warning
Event: 3250
Source: Enterprise Vault 
Category: Archive Task
Description:
The following message could not be archived as it may be corrupt. 
Title: failure to archive 
Mailbox: /o=Test/ou=First Administrative Group/cn=Recipients/cn=user

V-437-3250
 
Event Type: Warning
Event Source: Enterprise Vault
Event Category: Journal Task
Event ID: 2216
Description:
Message dispenser will suspend processing for 5 minutes due to a recoverable error 

V-437-2216
 
The following can be seen in a Dtrace of the ArchiveTask process on the Enterprise Vault during the archive run.  For more information on Dtrace please see the link in the Related articles section.  
 
(ArchiveTask) EV:H :CArchivingAgent::WriteWorkItemsToQueue() |Call to MakeItemPendingAndQueueMsg() failed |Mailbox: /o=Test/ou=First Administrative Group/cn=Recipients/cn=user|Message: failure to archive |Error Returned: 8007000e |
 

 

Cause

This message should be removed from the mailbox as it will not be archived due to corruption.  It will also cause other items not to be archived due to suspending the archiving process.  
 

Solution

Alternatively, the following can be performed instead of deleting the item.
 
Set Failed messages to 'Do Not Archive'
 
  1. Open the Vault Administration Console (VAC) and expand Directory on Server_name > Site_name > Policies > Exchange > Mailbox.
     
  2. Right-click on the policy name for the user experiencing the issue and select Properties.
     
  3. Select the Advanced tab and ensure List settings from: is set to Archiving General.  
     
  4. Change Set failed messages 'Do Not Archive' to On and click OK twice to exit the policy properties. 
     
  5. Synchronize the user mailbox to update it with the new policy information.  For more information on synchronization please see the link in the Related articles section.   
     
Note:  This change will affect all users using the policy once they have been synchronized.
 

 

References

Etrack : 2216 UMI : V-437-2216 Etrack : 3250 UMI : V-437-3250

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