Event ID 2243 Could not scan user mailbox error during archive run

Article: 100017939
Last Published: 2014-01-14
Ratings: 1 0
Product(s): Enterprise Vault

Problem

The following errors below occur during an archive run. This includes both scheduled and run now.

 

Error Message

Event Type: Error
Event Source: Enterprise Vault
Event Category: Archive Task
Event ID: 2243
Description:
Could not scan user mailbox /o=CompanyX/ou=First Administrative Group/cn=Recipients/cn=JohnDoe, cannot list messages

V-437-2243

 
Event Type: Warning
Event Source: Enterprise Vault
Event ID: 2270
Description:
A queued operation exceeded the retry count and has been discarded
m_pIBackgroundArchivingAgent->ProcessUserEx(Priority = "true",
ReportingMode = "false",
ContinuousMode = "true",
RollOverLogFile = "true",
NumMsgsToArchivePerPass = "200",
legacyMessageStoreDn = "",
LegacyMailboxDn = "/o=CompanyX/ou=First Administrative Group/cn=Recipients/cn=JohnDoe",
adMessageStoreDn = "",
adMailboxDn = ""
, NULL); 
HRESULT: 0x800B0001

V-437-2270

 

A Dtrace of the ArchivingTask may show an illegal character, represented as a in the folder path (bolded).

1342322 21:46:57.735 0 CFolderHelper::GFSFMO - Using folder pathname to open folder [?Misc?Foldertest]
1342323 21:46:57.735 0 HRXEX fn trace :|Source     : \Agents\AgentsCommon\FolderHelper.cpp (CFolderHelper::GetFolderSettingsForManualOperation) [lines {1033,1136,1156,1194,1196,1194,1196,1194}] built Jul 25 17:20:20 2006|Description: Call error 0x800b0001
1342324 21:46:57.735 0 CFolderHelper::GFSFMO() - Error 0x800B0001|Internal:\Agents\AgentsCommon\FolderHelper.cpp (CFolderHelper::GetFolderSettingsForManualOperation) [lines {1033,1136,1156,1194,1196,1194,1196,1194}] built Jul 25 17:20:20 2006
1342325 21:46:57.735 0 CFolderHelper::CreateArchiveFolderHierarchy Call to GetFolderSettingsForManualOperation returned [0x800B0001]
1342326 21:46:57.735 0 CFolderHelper::CreateArchiveFolderHierarchy - Exit [0x800B0001]
1342327 21:46:57.735 0 CArchivingAgent::processChunkOfMessages - Call to CreateArchiveFolderHierarchy Failed [0x800B0001]
1342328 21:46:57.735 0 EV~E Could not scan user mailbox /o=CompanyX/ou=First Administrative Group/cn=Recipients/cn=JohnDoe, cannot list messages

 

Cause

Mailboxes are sometimes migrated from different messaging systems into Exchange. If there are illegal characters (characters that cannot be read by Microsoft Exchange Server or Microsoft Outlook) within the folder path of a mailbox, this can cause issues with Enterprise Vault failing to archive the mailbox. 

It has also been seen where the same errors occur when there are two identical folders in the user's mailbox, or two folders with the same name, one with a trailing folder. 

 

Solution

  1. Perform a dtrace on the ArchiveTask process during a Run Now against the affected users' mailbox until the error occurs in the Enterprise Vault event log. Instructions for how to perform a dtrace can be found in article 000125000 found in the Related Articles section at the end of this article.
  2. Search for the following hexcode: 0x800B0001 and line below within the dtrace.
  3. Log into the mailboxes in question and modify the illegal characters for the folder in question.
  4. Run the archive task again or allow the scheduled run to archive the mailbox and confirm the errors are no longer present.
Note: In the case where there are two identical folders, remove the empty one from the mailbox.

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