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Article: 100017762
Last Published: 2015-05-05
Ratings: 0 0
Product(s): Enterprise Vault
Problem
When using Enterprise Vault (EV), the following error occurs: Event ID: 3230 - Timed out whilst waiting for the MAPI profile mutex.
Error Message
Event ID 3230 : "Timed out whilst waiting for the MAPI profile mutex."
V-437-3230
Cause
When using EV, this error message may be logged by any of the agent services ie. Archive, Retrieval, Public Folder Services/Tasks.
The error effectively means that a Messaging Application Programming Interface (MAPI) profile could not be created, or the connection to the Exchange server/s was lost.
However the error can occur for other reasons, including the following:
- Connection to the Global Catalog(GC) server/s could not be made or is lost.
- Connection to the Domain Controllers(DC) could not be made or is lost.
- Connection to the SQL server hosting the Enterprise Vault (EV) databases could not be made or is lost.
- Issues with Outlook and/or Collaboration Data Objects on the EV server.
- Mis-configured EV server.
A MAPI mutex error is a critical error, so when this occurs, the EV services and/or tasks are shutdown.
Solution
MAPI mutex errors can be minimised by performing the following:
- Restart of the Agent services/tasks on a daily basis. - This will clear/reset the MAPI resources in use or resources that could not be cleared successfully.
- Follow MAPI troubleshooting steps as documented in the following article: https://www.veritas.com/docs/000028303
- Follow procedures as per the following article: https://www.veritas.com/docs/000030848
- On very active EV servers, update the ProfileExpire registry key value on the Enterprise Vault server to a lower number.
Warning
: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
If the Enterprise Vault server runs a 32 bits OS:
HKLM\Software\KVS\Enterprise Vault\Agents\ProfileExpire
If the Enterprise Vault server runs a 64 bits OS:
HKLM\Software\Wow6432Node\KVS\Enterprise Vault\Agents\ProfileExpire
HKLM\Software\KVS\Enterprise Vault\Agents\ProfileExpire
If the Enterprise Vault server runs a 64 bits OS:
HKLM\Software\Wow6432Node\KVS\Enterprise Vault\Agents\ProfileExpire
The default for this setting is
3 . This represents the number of days before systematically created Outlook Profiles are expired. Changing this value to
1 (day) will expire the systematically created Outlook Profiles faster, improving overall Outlook performance.
Note: Setting this key to 0 will clear all Outlook profiles created by the EV services and tasks upon EV service restart; however, this key should be changed to a value greater than 0 for normal operation.