Duplicate archives created in Enterprise Vault (EV) for Microsoft Exchange

Article: 100017155
Last Published: 2015-09-23
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Product(s): Enterprise Vault

Problem

Duplicate archives created in Enterprise Vault (EV) for Microsoft Exchange

Cause

When a user is re-enabled for archiving, the archive to which the mailbox is associated keys off from a DefaultVaultID field contained in the ExchangeMailboxEntry table and a hidden message in Exchange. The ExchangeMailboxEntry table is located in the EnterpriseVaultDirectory database.

A duplicate archive is created for a user if the DefaultVaultID is blank at the time when the user account is re-enabled.

Solution

This article explains how to manually clean up duplicate archives. To do this, it is necessary to know which archive is the newer and whether the newer archive contains any data.

  1. Open SQL Management Studio.
     
  2. Click on the New Query button.
     
  3. Type the following SQL query:

    USE EnterpriseVaultDirectory
    SELECT * FROM VaultEntryView
    WHERE VaultName LIKE '%yourvaultname%'

    Note: Replace yourvaultname with the name of the duplicate archive.

    The results should display information regarding both archives as shown below:


    Figure 1
     
  4. Record the values for the VaultEntryID fields.
     
  5. Record the Vault Store database name for the Vault Store where the duplicate archives are located.
     
  6. Click on the New Query button.
     
  7. Type the following SQL query:

    USE VaultStoreDatabase
    SELECT * FROM ArchivePoint
    WHERE ArchivePointId LIKE '%VaultEntryID%'

    Note: Replace VaultStoreDatabase with the name of the  Vault Store database from step #5. In addition, replace VaultEntryID with one of the VaultEntryID values recorded from step #3.
     
  8. Note the number of ArchivedItems and the CreatedDate. This will help to determine which archive has the smallest number of items. Repeat steps 6 - 8 for the second archive.
     

If there are archived items in both archives, it will be necessary to restore all archived items from one archive back to the existing mailbox. Typically one would want to restore the archive with less data.

Afterwards, the secondary archive needs to be deleted within the Vault Administration Console (VAC). This would be the archive whose data was restored to the user's mailbox, or an archive that never had any data in it.

If multiple duplicate archives exist, all archived items must be restored from those archives to the existing mailbox. Failure to do so could result in lost data or associations within the vault store, leading to retrieval errors.

Note: To export items to another mailbox please follow steps from the Enterprise Vault Administrator's Guide or search for Export Wizard in your current version's Administrators Guide.

In order to confirm that the correct archive is being deleted, follow the steps below:

  1. In the Vault Admin Console, navigate to Archives > Exchange Mailbox > right-click the archive and select Properties.
  2. Click the Advanced tab.
  3. Confirm that the ArchiveID matches with the VaultEntryID from the steps above.
  4. Click OK.
  5. Right-click on the archive and select Delete.
  6. Once this is completed, follow this article to remove the hidden message with Enterprise Vault properties from the user's mailbox. This step needs to be performed because the hidden message also contains information regarding which archive the user's mailbox is associated with.
  7. Run the Enterprise Vault Provisioning Task to update the user's mailbox information.
  8. Re-enable the mailbox by selecting Tools > Enable Mailboxes in the Enterprise Vault Admin Console. The user's mailbox should appear as a New Mailbox. Once the mailbox has been re-enabled, the user will be associated with the correct archive.

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