Backup Exec Device and Media service fails to start with the message "Database specified does not exist"

Article: 100016726
Last Published: 2023-09-25
Ratings: 0 0
Product(s): Backup Exec

Problem

Backup Exec Device and Media service fails to start with the message "Database specified does not exist"

 

Error Message

The Database Specified does not exist or cannot be found.

 

Cause

If the Backup Exec Device and Media Service does not start with the error "Database specified does not exist," there might be a communication issue with the Backup Exec Database (BEDB) and Backup Exec application. The Backup Exec Database can be detached and re-attached to recover the connection.
 
Before detaching the database, verify if the correct server and instance name is reflected in the Adamm key.
 
 

Solution

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.

HKLM\Software\Veritas\Backup Exec for Windows\ADAMM\

Check the Database Server Name key to verify the server name. ( The key will not be present if it's using a local BKUPEXEC64 instance. )

If the instance name has changed, then the Database Instance Name key will also have to be changed to the new instance name. If the source system used a named SQL instance but the target now uses a default instance, then the instance name should be removed from the instance name key.

Note: If the Managed Media Server is not sharing the database with the Central Administration Server, then changing this ADAMM key should not be necessary. It should point to the local server, which is the Managed Media Server.
 

 
To detach and re-attach the Backup Exec Database using OSQL, perform the following:
 
Stop all the Backup Exec services
  • Open a command line window and connect to the Microsoft SQL Server instance
To connect to the Backup Exec instance,
 
Open Command prompt as administrator and type:
 
osql -E -S ServerName\BKUPEXEC64
 
The following prompt appears once successfully connected to the SQL Instance.
 
1>
 
This indicates a connection to the Backup Exec instance using OSQL. 
 
  • To detach the Backup Exec database, type the following command (Figure 1) at the OSQL prompt:
1>EXEC sp_detach_db BEDB
 
2>Go
 
 
Figure 1
 
 
 
  • To re-attach the database, type the following at the OSQL (1>) prompt (Figure 2)

1>EXEC sp_attach_db BEDB,
2>N'C:\Program files\Veritas\Backup Exec\Data\BEDB_dat.mdf',
3>N'C:\Program files\Veritas\Backup Exec\Data\BEDB_log.ldf'

4>Go  

(Note: If the database path is different, provide the correct path instead.
For Backup Exec 22.x, the default location will be "C:\Program files\Veritas\Backup Exec\Data\)  
 
 
Figure 2
 

 

  •  Try starting the Backup Exec services now.

 
Note: If Backup Exec is installed on a local SQL instance or if SQL tools are installed on the Backup Exec media server, then the above mentioned steps can be performed using the SQL Management Studio.

 
To detach the BEDB database using SQL Management Studio (SSMS): 
 
1. Connect to the Backup Exec  instance (BKUPEXEC64) using SSMS.
2. Right-click on the BEDB database.
3. Select T asks -> Detach (Figure 3)
 
Figure 3 
 
 
 
4. Click OK to confirm (Figure 4)
 
 
Figure 4
  
 
 
To re-attach the BEDB database:
 
1. Open the SQL Management Studio & connect to the Backup Exec instance (BKUPEXEC64)
2. Right-click on Databases.
3. Select  Attach (Figure 5)
 
Figure 5
 
   
 
4. In the Locate Database  Files window, provide the path to   BEDB_dat.mdf (default location is C:\Program Files\Veritas\Backup Exec\Data\BEDB_dat.mdf) and click OK as shown in (Figure 6)
 
     Figure  6
  
 
 
Once the BE database is attached successfully, start the Backup Exec services.
 

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