Important Update: Cohesity Products Knowledge Base Articles


All Cohesity Knowledge Base Articles are now managed via the Cohesity Support Portal: https://support.cohesity.com/s/searchunify. The Knowledge Base articles available here will not reflect the latest information or may no longer be accessible.

After installing Oracle Internet Directory application on a Unix client all full and differential backups are failing with an error code 41

Article: 100015907
Last Published: 2018-03-30
Ratings: 0 0
Product(s): NetBackup

Problem

After installing Oracle Internet Directory application on a UNIX client, full and differential, backups are failing with a status code 41 error.

 

Error Message

In the media server, bpbrm logs the following:

bpbrm Exit: client backup EXIT STATUS 41: network connection timed out

 

In the client, bpbkar logs the following:

bpbkar SelectFile: cwd=/oracle/fmw/oid_inst1 path=OID    <<== "SelectFile" Request
bpbkar PrintFile: /oracle/fmw/oid_inst1/OID/    <<== "PrintFile" Success: directory info received
bpbkar SelectFile: cwd=/oracle/fmw/oid_inst1/OID path=.oid_cache_pipe    <<== "SelectFile" Request

(The bpbkar log hangs here on the named pipe file '/oracle/fmw/oid_inst1/OID/.oid_cache_pipe' and file info is not received.)

 

Troubleshooting

For this case, add the VERBOSE entry to the client’s bp.conf file; to enable verbose logging:

# echo "VERBOSE" >> /usr/openv/netbackup/bp.conf

 

And as root on the client, run the following commands; to enable enhanced logging and create the log directory:

# touch /usr/openv/netbackup/bpbkar_path_tr
# /usr/openv/netbackup/logs/mklogdir bpbkar

 

Then retry the operation. The names of the files are logged on the debug log file in the /usr/openv/netbackup/logs/bpbkar directory before bpbkar processes them. The last file in the log is the file that causes problems, as indicated in the bpbkar logs snippet above.

 

Note: The UNIX file info for the named pipe file shows as follows:

# ls -la /oracle/fmw/oid_inst1/OID/.oid_cache_pipe
prw------- 1 oracle oinstall 0 Jul 21 08:06 .oid_cache_pipe 

 

Note: The UNIX 'tar' command fails to receive the file:

# tar cvf /dev/null /oracle/fmw/oid_inst1/OID/.oid_cache_pipe
tar: 0511-180 /oracle/fmw/oid_inst1/OID/.oid_cache_pipe is not a valid tar file type.

 

Cause

The bpbkar client process is hung on a file that is not a valid tar file type.

 

Solution

Suggest adding the named pipe file to the NetBackup Exclude list:

# echo "/oracle/fmw/oid_inst1/OID/.oid_cache_pipe" >> /usr/openv/netbackup/exclude_list

 

Per Oracle Support: If this named pipe is excluded, then the backup completes successfully. More information from Oracle can be found in the reference below.

Third-party Reference:

Server Backup (NetBackup) Hangs on the file $ORACLE_INSTANCE/OID/.oid_cache_pipe

Doc ID 2037054.1 - https://support.oracle.com/knowledge/Middleware/2037054_1.html

Veritas's site provides links to third-party web sites, which are not under the control of Veritas. Veritas makes no representations about third-party web sites. When you access a non-Veritas web site, you do so at your own risk. Veritas is not responsible for the reliability of any data, opinions, advice, or statements made on third-party sites. Veritas provides these links merely as a convenience. The inclusion of such links does not imply that Veritas endorses, recommends, or accepts any responsibility for the content of such sites.

 

Applies to:
Any supported Veritas NetBackup version
Oracle Internet Directory - Version 11.1.1 and later
Information in this document applies to any platform.

 

Was this content helpful?