Event ID: 13360 An error was detected while accessing the Vault Database

Article: 100014965
Last Published: 2015-01-28
Ratings: 0 2
Product(s): Enterprise Vault

Problem

Upon restarting the Enterprise Vault (EV) Storage service the event error 13360 is logged to the Veritas Enterprise Vault event log.

Error Message

Event ID: 13360
An error was detected while accessing the Vault Database '<VaultStoreDB>' (Internal reference: {CADODataAccess::ExecuteSQLCommand} [.\ADODataAccess.cpp, lines {1317,1319,1334,1352}, built Jun 29 21:09:37 2012]): |Description: |The DELETE statement conflicted with the REFERENCE constraint "FK_CollectionIdentity_Collection". The conflict occurred in database "<VaultStoreDB>", table "dbo.Saveset", column 'CollectionIdentity'.| | |SQL Command: | EVManageCollections| | |Additional Microsoft supplied information:| |Source: Microsoft OLE DB Provider for SQL Server |Number: 0x80040e2f |SQL State: 23000 |Native Error: 00000547

V-437-13360

Cause

Due to inconsistencies in the Vault store database if you check the collection table you will find items with a reference count of 0, but when EV attempts to remove them it checks the saveset table to ensure that they are not in use and finds that actually they are, so the constraint stops them being removed.

In the example EVSVR Verify Database Linkages log extract below, it is seen as 0 items on the Collection table when the actual count is 3 on the Saveset table

Collection Reference Counts do not match. VS DB TotalCount: 3, VS DB RefCount: 0, VS DB Saveset record count: 3, FP DB SISPart and Converted Content record count: 0

Solution

Step 1 - EVSVR Verify Database Linkages to confirm issue and highlight all affected items

  1. On the EV server open up a command prompt
  2. Browse to your Enterprise Vault installation location (typically c:\Program Files (x86)\Enterprise Vault\)
  3. Type in EVSVR and press enter
  4. Type in Edit and press enter
  5. In the EVSVR Operations window under locate the Operation to Perform section (bottom right)
  6. Select Verify from the Operation field
  7. Select DatabaseLinkages from the Option field
  8. Click on the Save button and save this xml file in the default location with a filename of your choice
  9. Click on the OK button
  10. You will now be back on the command prompt window, here type in Start and press enter
  11. Now wait until you get the prompt 'processing has stopped at '
    **This may take a long time to complete
  12. Locate and review the EVSVR log file within the 'Reports\EVSVR' folder (typically c:\Program Files (x86)\Enterprise Vault\Reports\EVSVR)


Step 2 - EVSVR Repair Database Linkages to repair all affected items

** Before running EVSVR take a backup of your Enterprise Vault databases and make sure that your Vault Store's are in backup mode and remain in backup mode during the duration of the EVSVR run **

  1. On the EV server open up a command prompt
  2. Browse to your Enterprise Vault installation location (typically c:\Program Files (x86)\Enterprise Vault\)
  3. Type in EVSVR and press enter
  4. Type in Edit and press enter
  5. In the EVSVR Operations window under locate the Operation to Perform section (bottom right)
  6. Select Repair from the Operation field
  7. Select DatabaseLinkages from the Option field
  8. Click on the Save button and save this xml file in the default location with a filename of your choice
  9. Click on the OK button
  10. You will now be back on the command prompt window, here type in Start and press enter
  11. Now wait until you get the prompt 'processing has stopped at '
    **This may take a long time to complete
  12. Locate and review the EVSVR log file within the 'Reports\EVSVR' folder (typically c:\Program Files (x86)\Enterprise Vault\Reports\EVSVR)

 
In the EVSVR Repair log, it can be seen that:

Repaired collection record - Reference Count set to 3

Once all of the collections table are consistent, Event error 13360 will no longer occur as the data is valid. 


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