Problem
Login failure when connecting to a NetBackup master server using the NetBackup 7.6.0.4 or 7.6.1 Java Administration Console
Error Message
NetBackup could not initiate a trust relationship with host hostname. Ensure that your Domain Name Service (DNS) resolves the hostname to the correct IP address and check network connectivity.
Cause
The hostname is likely to be a fully qualified domain name of the master server - but may not match that domain that you are trying to login to.
The NetBackup Java Administrator Console tries to establish a Transport Layer Security (TLS) channel with NetBackup, later producing a X.509 certificate. The certificate produced has the master server host name embedded in it which is used by the NetBackup Java Administrator Console to establish connection with NetBackup Authentication Service (nbatd) service. User is notified if the connection could not be established with nbatd service on the master server host as found in the X.509 certificate.
Establishment of connection could fail if:
- Host configuration or Domain Name Service (DNS) could not resolve host name as found in the X.509 certificate from machine executing NetBackup Java Administrator Console.
- nbatd service on the host is not started.
Solution
Network diagnostic system commands such as ping can be executed on the host where the NetBackup Java Administration Console is installed to verify if the host name is resolvable to correct IP address or not. If the host name resolution fails, then appropriate DNS or host configuration entries should be made to rectify the issue. Executing bpps -x on NetBackup Host lists all NetBackup processes that are currently running on the system. If nbatd is not mentioned as running on the system, restarting NetBackup would solve the problem.
Applies To
NetBackup 7.6.0.4 or 7.6.1 Java Administration Console running on Windows or UNIX