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FSAUtility requires a DNS entry in order for it to work

Article: 100014053
Last Published: 2026-01-08
Ratings: 1 0
Product(s): Enterprise Vault

Problem

FSAUtility requires a DNS entry in order for it to work. This is not desirable if, for example, the file server has been decommissioned but the administrator wants to restore all files using the FSAUtility -t command.

Error Message

In this example, the following command should restore all archived files under the Test1 directory and all subdirectories. The files should be restored to a server called EV-FSA in the Restored folder :-

FSAUTILITY -t -s \\FS2012DEAD.ev.com\Data\Test1\ -d \\EV-FSA.ev.com\Restored

In this instance the original file server FS2012DEAD no longer exists or its DNS A record entry has been deleted. The following error is presented in the command prompt:

Error: Invalid Server Name FS2012DEAD.ev.com

A Dtrace of the FSAUtility process shows the following error:

{CMDLINE.EN_US} Host FS2012DEAD.ev.com.local could not be found.
System.Net.Sockets.SocketException: No such host is known
|   at System.Net.Dns.GetAddrInfo(String name)
|   at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
|   at System.Net.Dns.GetHostEntry(String hostNameOrAddress)
|   at KVS.EnterpriseVault.FSARestoreCLI.CmdLine.ParseUNCPath(String[]commandlineargs, Int32& i, Boolean IsDestination)

Cause

The DNS A record for the file server does not exist.

Solution

Create a DNS entry for the file server or a hosts file entry on the EV server in the following format. 

IP_ADDRESS   FQDN   NetBIOS_name

Example: 10.10.10.10   FS2012DEAD.ev.com   FS2012DEAD

 

 

Veritas Corporation has acknowledged that the above-mentioned issue is present in the version(s) of the product(s) referenced in this article.

There are currently no plans to address this issue by way of a cumulative hotfix or service pack in the current or previous versions of the software at the present time. This issue may be resolved in a future major revision of the software at a later time, but is not scheduled for any release. If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns.  For information on how to contact Veritas Sales, please see https://www.veritas.com.

 

 

References

Etrack : 3611719

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