"V-16-10051-17134 Clustered MSMQ service is NOT bound to correct port" is reported when a clustered MSMQ instance fails to come online
Problem
A clustered MSMQ (Microsoft Message Queueing) instance may fail to come online after the initial configuration or OS or VCS level configuration changes.
Error Message
Cause
The clustered MSMQ service is not bound to the correct IP address, or port.
This can be validated by using the netstat command.
C:> netstat -abno | findstr 1801
Output:
TCP <localIP>:1801 0.0.0.0:0 LISTENING <PID>
TCP [::]:1801 [::]:0 LISTENING <PID>
If the virtual IP is not listed as <virtualIP>:1801, then the network bindings are incorrect. <localIP> will only be listed, if default MSMQ service is running.
Solution
1. Open the Registry Editor and locate HKEY_LOCAL_MACHINE\Software\Microsoft\MSMQ\Parameters
2. Create a new String value called BindInterfaceIP.
3. For this value, add the system's IP address.
4. Restart the Message Queue service.
5. Repeat steps 1-4 on all cluster nodes where the MSMQ resource can run.
6. Perform the following steps on the node where the service group that contains MSMQ is partially online with at least the RegRep resource and it's dependencies online.
7. Open the Registry Editor and locate HKEY_LOCAL_MACHINE\Software\Microsoft\MSMQ\Clustered QMs\MSMQ$<ResourceName>\Parameters.
8. Create a new String value called BindInterfaceIP.
9. Add the IP address attribute of the virtual IP configured for the MSMQ resource in VCS as the Value data entry for the new BindInterfaceIP value.
10. Bring the MSMQ resource online.
NOTE: If the port bindings still do not show the virtual IP binding to port 1801, then the article: Configuring MSMQ agent to check port bindings more than once can be followed to allow more time for the port bindings to complete.