"V-16-10051-17134 Clustered MSMQ service is NOT bound to correct port" is reported when a clustered MSMQ instance fails to come online

"V-16-10051-17134 Clustered MSMQ service is NOT bound to correct port" is reported when a clustered MSMQ instance fails to come online

Article: 100013300
Last Published: 2021-06-23
Ratings: 2 0
Product(s): InfoScale & Storage Foundation

Problem

A clustered MSMQ (Microsoft Message Queueing) instance may fail to come online after the initial configuration, or after a node reboot.

Error Message

V-16-10051-17134 Clustered MSMQ service is NOT bound to correct port.

Cause

The clustered MSMQ service is not bound to the correct IP address, or port.

This can be validated by using the the netstat command (Figure 1).

Figure 1 - Using netstat to check port 1801

netstat -abno | findstr 1801

Output:

TCP <localIP>:1801 0.0.0.0:0 LISTENING <PID>

TCP [::]:1801 [::]:0 LISTENING <PID>


If the virtual IP is not listed as <virtualIP>:1801, then the network bindings are incorrect. <localIP> will only be listed if default MSMQ service is running.  

Solution

1. Open the Registry Editor and locate HKEY_LOCAL_MACHINE\Software\Microsoft\MSMQ\Parameters

2. Create a new String value called BindInterfaceIP.

3. For the value add the systems IP address.

4. Restart the Message Queue service.

5. Repeat steps 1-4 on all cluster nodes where the MSMQ resource can run.

6. Perform the following steps on the node where the service group that contains MSMQ is partially online with at least the RegRep resource and it's dependencies online.

7. Open the Registry Editor and locate HKEY_LOCAL_MACHINE\Software\Microsoft\MSMQ\Clustered QMs\MSMQ$<ResourceName>\Parameters.

8. Create a new String value called BindInterfaceIP.

9. Add the IP address of the virtual IP configured for the MSMQ resource in VCS.

9. Bring the MSMQ resource online.


For more information about this registry key, refer to the following Microsoft article:

FIX: You cannot send or receive messages using Message Queuing 4.0 or Message Queuing 5.0
support.microsoft.com/kb/974813

References

UMI : V-16-10051-17134

Was this content helpful?