Unable to get - CPU Stats from WMI

Article: 100010341
Last Published: 2023-10-17
Ratings: 0 1
Product(s): eDiscovery Platform

Problem

Discovery has failed due to "cpu stats could not be gathered" error.  The remote job log may generate several errors in reference to " Unable to get - CPU Stats from WMI."

 

Error Message

Under the remote Job Log there may be several messages relating to CPU Stats or the inability to get CPU Stats from WMI. 

Examples under remotejob@46011.log:

2013-07-19 11:55:07,291 INFO [STDOUT] (remotejob:46011) [WARN ][XXXX ] Could not enumerate processes (1) error=-1073738819
2013-07-19 11:55:07,291 INFO [STDOUT] (remotejob:46011) [WARN ][XXXX ] Could not add counter (null)\ for query
2013-07-19 11:55:07,291 INFO [STDOUT] (remotejob:46011) [WARN ][XXXX ] Failed to init virtual size counter.
2013-07-19 11:56:07,291 ERROR [resource.cpu.RawStatCollector] ([TimedExecutor] pool-27-thread-1:) [#71000] Admin Services Error : Unable to get - CPU Stats from WMI.
2013-07-19 12:00:08,665 WARN [resource.cpu.CpuEventManager] (pool-1-thread-1:) [#71000] Admin Services Error : Unable to get CPU statistics - No CPU information.
2013-07-19 12:04:08,670 WARN [resource.cpu.CpuEventManager] (pool-1-thread-1:) [#71000] Admin Services Error : Too Many Errors - will reduce error report frequency. - No CPU information
2012-07-19 12:23:09,456 WARN [admin.shell.Lifecycle] ([TimedExecutor] pool-27-thread-1:) [#72002] Delayed Shutdown (reason: CPU Stats from WMI not available.):


 

Cause

There are two possible causes for this scenario: 

1. Windows Management Instrumentation is not running.

2. Windows Performance Counter has failed

 

Solution

To make sure the Windows Management Instrumentation is running perform these steps:

1. Navigate to: Control Panel > Administrative Tools > Services

2. Double click on Windows Management Instrumentation

3. Set Startup type to Automatic

4. Confirm that the service is started

5. Retry task

 

If the above steps do not resolve the issue it may be required to rebuild the performance counters.

1. Navigate to: Control Panel > Administrative Tools > Services

2. Stop the ESAApplicationService : FireDaemon

3. Open a command line as an administrator and type: lodctr /r

4. Press enter.

5. Check to verify that all performance counters were enabled

       A.  In command line type: lodctr /q   (This will list all counters - enabled and disabled)
       B.  Press enter.

6. Start the ESAApplicationService : FireDaemon

7. Retry Task

 

 

 

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