Problem
Accelerator Backup Job fails with error: accelerator verification failed, resulting in a Status Code 84.
Error Message
10/14/2018 13:44:27 - begin writing
10/14/2018 21:09:24 - Critical bptm (pid=2772) accelerator verification failed: backupid=hostname_XXXXXXXX, offset=23761920, length=512, error=2060022, error message: software error
10/14/2018 21:09:24 - Critical bptm (pid=2772) image write failed: error 2060022: software error
10/14/2018 21:09:28 - Error bptm (pid=2772) cannot write image to disk, Invalid argument
10/14/2018 21:09:28 - Info bptm (pid=2772) EXITING with status 84 <----------
10/14/2018 21:09:29 - Info bpbkar (pid=2812) done. status: 84: media write error
10/14/2018 21:09:29 - end writing; write time: 7:25:02
media write error (84)
Cause
In an Accelerator-enabled backup, the NetBackup client keeps record of all blocks being backed up in the track log, which reside in the following locations:
Windows: install_path\NetBackup\track
UNIX/Linux: /usr/openv/netbackup/track
During the next backup, only changed blocks are sent to the media server by the client. On the media server, the current backup is formed by combining the previous backup and changed data received. In this scenario, the backup is failing because Accelerator could not verify the previous backup image.
To confirm this, run an image verification job on the previous backup ID, the image should be rehydrated, however the image verification may fail with the following error:
Critical bpdm(pid=xxxx) The size of backup id hostname_XXXXXXXX fragment 7 for copy 1 does not match the size found on media (51656052224 51656051712)
This indicates that there was size mismatch for the fragment stored on the media server and the size recorded in the catalog.
Alternatively, if the FULL backup with Accelerator forced rescan enabled is failing, the client's track log may have been corrupted and would need to be manually removed.
Solution
Here are some options which may resolve this issue...
Option 1:
Create a new policy and run a FULL backup. After the first successful FULL backup, the subsequent accelerator-enabled backup job should complete successfully.
Option 2:
Alternatively, clearing the track logs from the client and running a new FULL backup, with Accelerator forced rescan enabled, should complete successfully.