Browse of a Granular Recovery Technology (GRT) enabled backup fails with "ERROR: database system error"
Problem
Browse of a Granular Recovery Technology (GRT) enabled backup fails with "ERROR: database system error"
This issue can affect GRT enabled backups of Exchange, SharePoint, and Active Directory.
Error Message
ERROR: database system error
Consult the nbfsd log on the client on which you have launched the Backup, Archive and Restore GUI for evidence of the following:
09:10:46.287 [6948.3760] <16> _nbfs_connect: WNetAddConnection2() failed, error = 1222
Cause
This problem can occur if the Client for NFS service on the client is not installed, not started or not functioning properly.
Solution
If the NFS service is not installed, install it as per the guide below:
- Reference: Veritas NetBackup™ for Microsoft Exchange Server Administrator's Guide
About installing and configuring Network File System (NFS) for Exchange Granular Recovery
If the NFS service is not started or it is suspected that the service is not functioning properly, restart the service.
Warning: Do not use the Microsoft Services snap-in to stop the service. Doing so may result in a need to reboot the system in order to start the service.
To stop and restart the NFS service, this should be done via the Windows OS nfsadmin command:
nfsadmin client stop
nfsadmin client start
3rd Party Reference: Windows Server Commands > nfsadmin