Granular Recovery Technology (GRT) enabled Exchange backup and catalog metadata jobs complete successfully, but no GRT restore selections are available from the backup set.

Article: 100008962
Last Published: 2023-10-20
Ratings: 0 0
Product(s): Backup Exec

Problem

After completing a successful GRT enabled Exchange backup and catalog metadata job, and attempting to browse restore selections, no individual items are available for restore from the backup set.

Error Message

An Backup Exec Debug Monitor (SGMon) output reveals the following during the Catalog Metadata job:

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BEREMOTE: [fsys\mb2]           - m2chgdir:ChangeDir() temp is using pdi backup path (0)
BEREMOTE: [fsys\mb2]           - m2chgdir:ChangeDir() error based on no pdi backup temp path usable
BEREMOTE: [fsys\mb2]           - MB2_Chgdir:Logon returned e000fea9
BEREMOTE: [ndmp]               + BackupDirector.h (518):
BEREMOTE: [ndmp]               | Post-processing files
BENGINE:      [server]             - Error: CatalogMessageHandler encountered an unexpected message: class eng_msgs::extended_error.
---------------------------------------------------------------------------------------------------------

Cause

Certain conditions on the machine volumes were not accounted for when attempting to mount the database for virtual staging.  For instance, if the largest volume on the machine is not mounted, Backup Exec will improperly attempt to use it for virtual staging due to the logic which chooses the staging location.

Solution

Set the virtual staging location for GRT (OnHostTemp) from the media server manually:

Note: No parenthesis required for the string or string value on steps #3 and #4):

  1. On the Media  Servers, click Start >> Run and type "regedit".  Click OK.
  2. In the Registry Editor, navigate to HKLM\SOFTWARE\Symantec\Backup Exec For Windows\Backup Exec\Engine\Exchange
  3. Right click and add a new String Value, “OnHostTemp".
  4. Right click and set the value of OnHostTemp to "c:\temp".
  5. Restart all the Backup Exec Services and run the backups.

 

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Veritas Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned at the end of this article. Veritas Corporation is committed to product quality and satisfied customers.
 
There are no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. However, the issue is currently scheduled to be addressed in the next major revision of the product. Please be sure to refer back to this document periodically as any changes to the status of the defect will be reflected here.  Please note that Veritas Corporation reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests.  Veritas's plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.
 

Please contact your Veritas Sales representative or the Veritas Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.  For information on how to contact Veritas Sales, please see    https://www.veritas.com  
 

Applies To

This issue has been observed within environments using a remote Backup to Disk location on a NAS device, such as a Buffalo Terastation.

References

Etrack : 2870100

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