When replacing a master server, the catalog recovery is failing.

Article: 100008752
Last Published: 2012-08-20
Ratings: 0 1
Product(s): NetBackup & Alta Data Protection

Problem

After a master server has been replaced and the catalog recovery starts, TAR is unpacking images then suddenly fails with status 5.

Error Message

EXIT STATUS 5: the restore failed to recover the requested files
ERR – Failed to execute the command C:\Program Files\Veritas\NetBackup\bin\bprestore.exe –w –T –X –C <master_server> -t 35 –p CatalogBackup –e <ctime> -priority 90000 –L “C:\Program Files\Veritas\NetBackup\Logs\user_ops\nbadmin\logs\xxxxx.log” / on host <master_server> (5)

Cause

An ALTPATH file on the old master server was redirecting a client's backup images to a D:\ drive on the old master server. The D: drive is not present on the new server.

Solution

There are three possible solutions.

  1. Define the D: drive appropriately on the new master server.
  2. Temporarily move the image files from D: drive back into NetBackup\db\images\<client> and remove the ALTPATH file. Then perform a new catalog backup on the old master server before the catalog recovery.
  3. If the client has never housed important data, so there is no reason for it to be restored in the future, then expire the images stored on the D: drive, then delete the ALTPATH file from C:\Program Files\Veritas\NetBackup\db\images\<client>\ALTPATH and run another hot catalog backup on the old master server. This will cause the references to the old images to not be included in the next catalog backup of the old master and therefore not be included during the catalog recovery on the new master.

 

Applies To

The old master server was Windows 2003 x86, new server is Windows 2008 x64.
Same netbackup version was installed on the new netbackup master server.
The new server has the same host name and IP address as the old one.

Was this content helpful?