Problem
Journal or Mailbox email items remain in a pending state. There is also a build up of messages in the A2 and J2 MSMQ's. These messages never get processed.
Error Message
Event Type: Error
Event Source: Enterprise Vault
Event Category: Archive Task
Event ID: 3007
Computer: EVServer01
Description:
Could not build a saveset for the message titled RE: Message failed to archive /o=EV/ou=Archive/cn=Recipients/cn=archive user, function CArchivingAgent::PI_BuildSaveset failed
Error returned = 0x80004005
V-437-3007
Event Type: Error
Event Source: Enterprise Vault
Event Category: Archive Task
Event ID: 2244
Computer: EVServer01
Description:
An error occurred whilst processing the message titled: RE: Message failed to archive /o=EV/ou=Archive/cn=Recipients/cn=archive user, the message will not be archived and could not be changed back from the Archive Pending state.
V-437-2244
Event Type: Warning
Event Source: Enterprise Vault
Event Category: Archive Task
Event ID: 2270
Computer: EVServer01
Description:
A queued operation exceeded the retry count and has been discarded
m_pIBackgroundArchivingAgent->ProcessItemEx(Priority = "false",
ExchangeSystem = "MAILVS1",
m_pILocation,
(ULONG)EntryIdSize = 70,
EntryId,
VaultId = "19ADA33A79CB7B547A3738E09255EF6CF1110000EVSERVER01",
ArchiveId = "1428543D85D80BD46B39749914512E8091110000EVSERVER01",
RetentionCategory = "1C3095515EBC2B04B83E5B8CFD76BA6781b10000EVSERVER01",
UserMailboxDn = "/o=exdomain/ou=First Administrative Group/cn=Recipients/cn=User1",
MessageTitle = "January 1, 2009 Pay Date",
nRetryCount = 3,
NULL,
CallerSID,
isAReArchive = 1, ArchiveTransId = "90D3B70580E2C5563CF6F8EB95835171", IndexedPropertiesSet = "");
HRESULT: 0x8004011B
V-437-2270
Cause
Dtrace of the JournalTask or ArchiveTask shows the following:
{GetExchangeServerValues:#4291} Exchange DN: [CN=EXCH01,CN=Servers,CN=EV,CN=Administrative Groups,CN=EXCH,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=EV,DC=com]|Exchange AD search path: [(null)]|Exchange FQDN: [EV.COM]
Solution
There are 2 solutions to this issue.
Solution 1
Set a specific Global Catalog (GC) server in the Enterprise Vault Administration console.
1. Expand Enterprise Vault | Directory On.. | SiteName | Targets | Exchange | Properties of the Domain
2. Check the box to Use specific Global Catalog Server and enter a known good GC using the Fully Qualified Domain Name.
Solution 2
Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
Apply the DS Server registry key using the path described in this article: https://www.veritas.com/support/en_US/article.100003011.html
Note: ClosestGC registry key will not work in this instance and the comments in regards Microsoft Exchange 2010 within the Microsoft article.