Error status - backup error 13 file read failed. Job details show 'socket read failed: errno = 62 - Timer expired'
Problem
A file system backup (Standard or Windows policy) fails with Exit Status 13
Error Message
The bpbrm debug log and Job Detailed Status show the following error:
15:24:07.908 [31147] <2> bpbrm mm_sig: received ready signal from media manager
15:29:07.908 [31147] <16> bpbrm readline: socket read failed: errno = 62 - Timer expired
15:29:30.716 [31147] <2> bpbrm Exit: client backup EXIT STATUS 13: file read failed
Cause
The NetBackup Backup and Restore Manager (bpbrm) has not received any progress updates from the client host in recent minutes. In the example above, this was after exactly 5 minutes, which is the default value (300 seconds) for the CLIENT_READ_TIMEOUT, as configured under the Host Properties of the Media Server within the NetBackup Administration Console.
- Host Properties > Media Servers > my_media_server > Timeouts > Client Read Timeout
Some clients may experience this problem when backing up very large file systems, very active file systems, or file systems with many small seldom-changing files. In those cases, the client may spend more time finding/reading files to backup than it does actually transferring the files to storage.
Note: This same symptom can occur if the backup transfer is actually hanging, or if the network is congested and increasing this value may expose the compounding environmental issues. For more details, see the Related Knowledge Base Articles below.
Solution
Suggest increasing the Client Read Timeout in the media server's Host Properties, by doubling the value from 300 to 600, and continue to increment the value until the backup is successful.