Problem
Compliance Accelerator (CA) and Discovery Accelerator (DA) use TCP/IP port 8086 for client-to-server and server-to-client communications.
Cause
There can be occasions where the need exists to confirm the TCP Port used by the Compliance Accelerator (CA) or Discovery Accelerator (DA) client to communicate with the CA or DA server. This document provides the information needed to confirm the TCP Port that these clients are supposed to be using.
Solution
The client/server communication port can be confirmed in the AcceratorClient.Exe.Config file that should be located in the client installation folder of the client machine. The examples below are for a default client installation.
C:\Documents and Settings\<user>\Local Settings\Application Data\Enterprise Vault Compliance Accelerator\Client\
C:\Documents and Settings\<user>\Local Settings\Application Data\Enterprise Vault Discovery Accelerator\Client\
To confirm the port used on the client machine, follow steps below:
- Locate and open the AcceratorClient.Exe.Config file from the client machine using notepad.
- Click on Edit > Find and search for "AcceleratorServerPort".
- Its value should be listed as 8086 as noted in Figure 1 below.
Figure 1. Screen shot of the 'AcceleratorClient.Exe.Config' file contents showing the TCP/IP port assignment.
Notes:
- If another application is using or a firewall is blocking this port, the file can be edited to use another open port by editing the port number and saving the file. An edit to the configuration files on the CA / DA server must also be completed to match the port specified when editing this file.
- All clients will have to have the same edit completed in order to access the CA / DA server upon completion of the port change.
- See Appendix A in the the version-specific Installation Guide shipped with the product for more information on how to change the ports that CA/DA use.