Email retrieval fails after installing Security Patch for Outlook 2010, 2013 and 2016

  • Modified Date:
  • Article ID:000127958

Problem

Users will not be able to retrieve emails after installing the associated Microsoft Outlook Security patch, listed below, released on September 12, 2017.

When this Microsoft Security patch for Outlook is installed on the client, users are unable to access archived emails.Upon double clicking on the shortcut it will open the shortcut only with the banner: "The item has archived by Enterprise vault. Click here to view the original link"

Outlook will become unresponsive, when clicking on the banner.

To determine if this patch has been installed, this command may be run from an elevated command prompt (Run as Administrator):

systeminfo | findstr "KB4011089 KB4011090 KB4011091"

Cause

These Microsoft Office security updates have disabled scripts for custom forms. Enterprise Vault's archived item shortcuts are custom forms that require scripting for their retrieval functionality.

Note: Outlook clients without this patch are not affected.
 

Workaround


Use the DisableCustomFormItemScript and TrustedFormScriptList Registry settings to allow scripting for Enterprise Vault shortcuts. This Microsoft KB article describes the usage of these settings. The Enterprise Vault custom forms that need to be added to the TrustedFormScriptList are:
IPM.Note.EnterpriseVault.PendingArchive
IPM.Note.EnterpriseVault.PendingArchive.ArchiveMe
IPM.Note.EnterpriseVault.Shortcut.DeleteMe
IPM.Note.EnterpriseVault.Shortcut.RestoreMe
IPM.Note.EnterpriseVault.Shortcut

The Registry location for these settings varies by the version of Outlook and the bitness of the operating system. For convenience, Veritas has made available a downloadable zip file containing Registry Entries (.reg) files to create the required settings to enable scripting for Enterprise Vault's custom forms on each supported version of Outlook.

To create the Registry settings on an affected machine:
  1. Download the zip file attached to this article and extract it.
  2. Browse to the folder for the appropriate version of Outlook.
  3. Choose the .reg file for the appropriate bitness of Outlook and Windows. For example, if you are running a 32-bit installation of Outlook 2010 on a 64-bit installation of Windows, choose EVClient_OL2010x86_Winx64.reg.
  4. On the affected workstation, import the contents of the .reg file by double-clicking it or by using File > Import from the Regedit application.
  5. Restart Outlook on the affected workstation.
The Registry settings can also be applied to a large number of machines using Group Policy.

As an alternative to modifying the Registry, users can also access their archived items via Enterprise Vault Search instead of using shortcuts.

Solution


This issue has been corrected in the following release:

Enterprise Vault 12.2.1
https://www.veritas.com/support/en_US/article.000127352

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