Backup Sets containing SQL database backups may expire prematurely.

  • Modified Date:
  • Article ID:000126395

Problem

Baseline SQL full or prior incremental backups may expire even when it has some unexpired incremental backups dependent on it. This issue may occur when all of the following conditions are met:

 
1) User databases are backed up in the same backup job with the SQL System databases (Master, Model, MSDB).
2) Both Full and Incremental (Automatic or Differential (block level) or incremental (block level)) backup types are being performed of the SQL instance.
3) The retention period of the full backup or earlier incremental backup has expired
4) A depending incremental or differential backup set has not yet expired.


 
In this scenario when the Incremental SQL backups are run, the SQL system databases will automatically be switched to 'full' backups in a new backup set since non-full backup types are not possible on system databases. MS Article. This switch to a ‘full’ backup creates a new backup set chain within Backup Exec, breaking the dependencies of all the selected databases in this backup job, including User databases. The previous SQL Incremental backup sets will no longer depend on the prior ‘full’ or prior ‘incremental’ backups. If the ‘full’ or prior ‘incremental’ backup set expires, it may be deleted, as the recovery chain protecting those sets is broken.


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Cause

When the system databases are automatically switched to a full backup method during an incremental backup job, it removes the dependency on the prior backups from the associated user database backup set.  Since the prior full and incremental backups are no longer part of the dependency chain, they can be deleted if the retention period expires before the depending incremental backups.

Solution

Workaround

To work around this issue, perform either A) or B)

A)  Edit the backup solution such that the Full backup job has a retention setting greater than that of the incremental job so that the Full does not expire before the Incremental has expired.
B) Back up the SQL databases in a separate job from the user databases.



Veritas Technologies LLC has acknowledged that the above-mentioned issue is present in the current version(s) listed under the Product(s) Section of this article. Veritas Technologies LLC is committed to product quality and satisfied customers.
 
There are currently no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. This issue may be resolved in a future major revision of the software at a later time. However, this particular issue is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns.  For information on how to contact Veritas Sales, please see http://www.veritas.com
 
Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.

 

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