Start-EVDatabaseUpgrade cmdlet fails after migrating to a new server using the Server Settings Migration Wizard

Article: 100033708
Last Published: 2023-11-21
Ratings: 0 0
Product(s): Enterprise Vault

Problem

When you run the Start-EVDatabaseUpgrade cmdlet from the Enterprise Vault Management Shell following the migration to a new EV 12 server with the EV Server Settings Migration Wizard, you may encounter the error below.

Note: The error occurs if you run the Start-EVDatabaseUpgrade cmdlet prior to starting the Enterprise Vault Directory service on the destination server.

Error Message

In the Enterprise Vault Management Shell window:



Start-EVDatabaseUpgrade : A required Enterprise Vault registry value is empty
or missing. Key: 'DirectoryService' value: 'Database Name'. This issue is
preventing the upgrade of the database. You must run the database upgrade on a
server with a full Enterprise Vault installation. You cannot run the upgrade
from a remote server. If you are running on a full Enterprise Vault server you
should re-run the Enterprise Vault Configuration Wizard.
At line:1 char:1
+ Start-EVDatabaseUpgrade
+ ~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (:) [Start-EVDatabaseUpgrade],
    UpgraderException
    + FullyQualifiedErrorId : RegKeyReadError,Symantec.EnterpriseVault.Databas
   e.DBUpgraderPowerShell.PSUpgraderLog


From the Event Viewer on the destination server:

Log Name: Veritas Enterprise Vault
Source: Enterprise Vault
Date: 08/02/2017 16:06:09
Event ID: 41533
Task Category: Database Upgrader
Level: Error
Keywords: Classic
User: N/A
Computer: EV1.DEMO.COM
Description: The database upgrader running on 'EV1' server failed. Failed to upgrade. A required Enterprise Vault registry value is empty or missing. Key: 'DirectoryService' value: 'Database Name'. This issue is preventing the upgrade of the database. You must run the database upgrade on a server with a full Enterprise Vault installation. You cannot run the upgrade from a remote server. If you are running on a full Enterprise Vault server you should re-run the Enterprise Vault Configuration Wizard.

Cause

The Registry entry containing the name of the EnterpriseVaultDirectory database is created incorrectly by the Server Settings Migration Wizard.
 

Solution

This issue has been addressed in the following release:

July 2017 release of the Enterprise Vault Server Settings Migration Wizard.
https://www.veritas.com/support/en_US/article.000107844

Workaround:

Correct the name of the Registry entry.

Method one (PowerShell) Rename-ItemProperty -Path 'HKLM:\SOFTWARE\Wow6432Node\KVS\Enterprise Vault\Directory\DirectoryService' -Name "databaseName" -NewName "Database Name"

Method two (Registry Editor)
1. Open Regedit
2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\KVS\Enterprise Vault\Directory\DirectoryService
3. Right-click on the "databaseName" entry and choose Rename
4. Change the name to "Database Name"

Once the name has been changed, retry the Start-EVDatabaseUpgrade cmdlet.

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.

References

Etrack : 3911866

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