VMware file level restore to the same client or alternate client failed. Error 12. File open failed.

Article: 100033468
Last Published: 2018-09-25
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

A VMware file level restore to the same client or alternate client failed with error bprd.sfr: read_rename_file: Couldn't open /usr/openv/netbackup/logs/user_ops/root/logs/jbp-xxxxxxxxxxxxxxxxxx.chg on client xxxx, status 2 in bprd log.

Error Message

The following may be seen in the bprd log:

17:03:47.183 [9951.9951] <8> do_pbx_service: [vnet_connect.c:2227] via PBX VNETD CONNECT FROM 10.10.0.72.54620 TO 10.10.0.102.1556 fd = 22
17:03:47.183 [9951.9951] <8> vnet_vnetd_connect_forward_socket_begin: [vnet_vnetd.c:440] VN_REQUEST_CONNECT_FORWARD_SOCKET 10 0xa
17:03:47.255 [9951.9951] <8> vnet_vnetd_connect_forward_socket_begin: [vnet_vnetd.c:457] ipc_string /usr/openv/var/tmp/vnet-25025483481027245886000006985-Tkai4W
17:03:47.339 [9951.9951] <2> bpcr_get_version_rqst: bpcd version: 07610000
17:03:47.341 [9951.9951] <16> bprd.sfr: read_rename_file: Couldn't open /usr/openv/netbackup/logs/user_ops/root/logs/jbp-08048483481024064594000000110-eG7It4.chg on client server10, status: 2
17:03:47.342 [9951.9951] <16> bprd.sfr: sfr: aborting entire restore:  error 12
17:03:47.342 [9951.9951] <4> bprd.sfr: sfr: Reached done, error: 12
17:03:47.385 [9951.9951] <2> jmcomm_ReleaseAllResourcesForJob: releaseAllResources returns [0]
17:03:47.385 [9951.9951] <2> jmcomm_ReleaseAllResourcesForJob: returning
17:03:47.385 [9951.9951] <2> restorefiles: Last attempt to restore from image = sourceclient01_1482948394 failed (browse_client = sourceclient01 destination_client = targetclient requesting_client = server10 user = root): file open failed
17:03:47.385 [9951.9951] <2> restorefiles: Restoring from image = sourceclient01_1483406180 (browse_client = sourceclient01, requesting_client = server10, user = root)
17:03:47.385 [9951.9951] <2> send_operation_to_monitor: Sending Operation [32] to activity monitor
17:03:47.580 [9951.9951] <2> jmcomm_PrintMediaResults: requestStatus is 0
17:03:47.580 [9951.9951] <2> jmcomm_PrintMediaResults: allocationId : {803CF088-D200-11E6-A06C-94BE4224E1E0}
17:03:47.580 [9951.9951] <2> jmcomm_PrintMediaResults: results.mdr_AllocationKey : 5140026
17:03:47.580 [9951.9951] <2> jmcomm_PrintMediaResults: results.mdr_TpReqFileName :
17:03:47.580 [9951.9951] <2> jmcomm_PrintMediaResults: results.mdar_MediaServer: mediaserver01
17:03:47.580 [9951.9951] <2> jmcomm_PrintMediaResults: results.mdar_MediaServerVersion : 772000
17:03:47.580 [9951.9951] <2> jmcomm_PrintMediaResults: results.mdar_MediaServerClusterName
asdf

Log location:

UNIX/Linux: /usr/openv/netbackup/logs/bprd
Windows: install_path\NetBackup\logs\bprd

Cause

The restore is trying to access the logs directory of the master server as defined by CLIENT_NAME.

In this example...

  • The bp.conf file on the master server had two CLIENT_NAME entries.
  • One CLIENT_NAME value was the master server.
  • The other CLIENT_NAME value was for server10, which was the problem.

Solution

Edit the bp.conf file on the master to remove the CLIENT_NAME that is not the master server hostname.

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