Problem
Backup job for a remote client is failing and the bptestbpcd test fails with: EXIT status = 25 cannot connect on socket.
Error Message
bptestbpcd: cannot connect on socketEXIT status = 25
bptestbpcd shows the following output:
15:31:34.554 [6088.4868] <16> connect_to_service: connect failed STATUS (18) CONNECT_FAILED
status: FAILED, (11) TIMEOUT; system: (10036) A blocking operation is currently executing. ; FROM 0.0.0.0 TO xx.xx.xx.xx 172.17.21.125 vnetd VIA pbx
status: FAILED, (11) TIMEOUT; system: (10036) A blocking operation is currently executing. ; FROM 0.0.0.0 TO xx.xx.xx.xx 172.17.21.125 vnetd VIA vnetd
15:31:34.570 [6088.4868] <8> vnet_connect_to_vnetd_ipi: [vnet_connect.c:258] connect_to_service() failed 18 0x12
15:31:34.570 [6088.4868] <16> bpcr_vnetd_connect_forward_socket_begin: vnet_connect_to_vnetd_ipi(xx.xx.xx.xx) failed: 18
15:31:34.586 [6088.4868] <2> local_bpcr_connect: bpcr_vnetd_connect_forward_socket_begin failed: 25
15:31:34.586 [6088.4868] <2> ConnectToBPCD: bpcd_connect_and_verify(servername, servername) failed: 25
<16>bptestbpcd main: Function ConnectToBPCD(servername) failed: 25
15:31:34.601 [6088.4868] <16> bptestbpcd main: Function ConnectToBPCD(servername) failed: 25 <2>bptestbpcd: cannot connect on socket
15:31:34.601 [6088.4868] <2> bptestbpcd: cannot connect on socket <2>bptestbpcd: EXIT status = 25
15:31:34.601 [6088.4868] <2> bptestbpcd: EXIT status = 25 cannot connect on socket
VNETD log shows the following output:
15:56:42.237 [4748.7244] <2> logparams: C:\Program Files\Veritas\NetBackup\bin\vnetd.exe -standalone
15:56:42.237 [4748.7244] <8> file_to_cache_item: [vnet_addrinfo.c:6555] fopen() failed ERRNO=2 FILE=C:\ProgramFiles\Veritas\NetBackup\var\host_cache\1ff\ffffffff+vnetd,1,1,0,1,0+.txt
15:56:42.241 [4748.7244] <8> ProcessRequests: [.\vnetd.c:635] msg VNETD ACCEPT FROM xx.xx.x.xx.57059 TO xx.xx.xx.xx.13724 fd = 564
15:56:42.242 [4748.7244] <8> vnet_pop_byte: [vnet.c:1168] errno 0 0x0
15:56:42.242 [4748.7244] <2> vnet_pop_byte: vnet.c.1170: 0: Function failed: 9 0x00000009
15:56:42.242 [4748.7244] <2> vnet_pop_string: vnet.c.1250: 0: Function failed: 9 0x00000009
15:56:42.242 [4748.7244] <2> vnet_pop_signed: vnet.c.1293: 0: Function failed: 9 0x00000009
15:56:42.242 [4748.7244] <2> vnet_version_accept: .\vnetd.c.1089: 0: Function failed: 9 0x00000009
15:56:42.242 [4748.7244] <8> ProcessRequests: [.\vnetd.c:640] version_accept failed 9 0x9
Cause
This issue will arise as a result of communication issues on the VNETD port.
Solution
1. Test the connection using the bptestbpcd command :
- Windows: <Install_Path>\VERITAS\NetBackup\bin\admincmd\ bptestbpcd -client <CLIENTNAME> -connect_options 1 0 2
- Unix: /usr/openv/netbackup/bin/admincmd/ bptestbpcd -client <CLIENTNAME> -connect_options 1 0 2
2. If this works, update the settings of the client on the master server using the bpclient command as shown below.
The command is run from the following location:
- Windows: <Install_Path>\VERITAS\NetBackup\bin\admincmd\
- Unix: /usr/openv/netbackup/bin/admincmd/
a. Command to run for existing clients:
bpclient -update client <CLIENTNAME> -connect_options 1 0 2
b. If the client is new or not listed in the client list, then use -add rather than -update:
bpclient -add client <CLIENTNAME> -connect_options 1 0 2
c. Once the bpclient has been run, test the connection again using:
bptestbpcd -client <CLIENTNAME>
3. Test the backup job to confirm the issue has been resolved.