Report not Completing on the Management Server.

Article: 100023646
Last Published: 2023-08-21
Ratings: 0 0
Product(s): Data Insight

Problem

The final report is failing to complete on the DI Management Server.

Error Message

2015-08-04 14:41:58 INFO:    #{1.EN_US} [ReportGenerator.init] Initializing Birt Engine
2015-08-04 14:41:58 INFO:    #{1.EN_US} [ReportGenerator.init] Setting Birt Engine HOME : E:\Program Files\Symantec\DataInsight\\reports\ReportEngine_1
2015-08-04 14:47:23 SEVERE:  #{1.EN_US} [ReportsUtils.main] Error processing reports
java.lang.OutOfMemoryError: GC overhead limit exceeded
    at org.eclipse.datatools.connectivity.oda.consumer.helper.OdaResultSet.getString(OdaResultSet.java:239)

Cause

The report engine is running out of memory.

Solution

  1. Logon to DI console  
  2. Navigate to Settings -> Inventory -> Data Insight Servers  
  3. From server list, select Management Server, click on Advanced Settings tab  
  4. Click on Set custom properties  
  5. Set property name = report.max.memory.output  
  6. Set property value = 4096 (Default memory is 2Gb which is not sufficient)  
  7. Click Save  
  8. Wait for a couple of minutes for replication of the configuration database and then rerun the report.  

Was this content helpful?