Report not Completing on the Management Server.

Article: 100023646
Last Published: 2023-08-21
Ratings: 0 0
Product(s): Data Insight

Problem

The final report is failing to complete on the DI Management Server.

Error Message

2015-08-04 14:41:58 INFO:    #{1.EN_US} [ReportGenerator.init] Initializing Birt Engine
2015-08-04 14:41:58 INFO:    #{1.EN_US} [ReportGenerator.init] Setting Birt Engine HOME : E:\Program Files\Symantec\DataInsight\\reports\ReportEngine_1
2015-08-04 14:47:23 SEVERE:  #{1.EN_US} [ReportsUtils.main] Error processing reports
java.lang.OutOfMemoryError: GC overhead limit exceeded
    at org.eclipse.datatools.connectivity.oda.consumer.helper.OdaResultSet.getString(OdaResultSet.java:239)

Cause

The report engine is running out of memory.

Solution

  1.  In the Data Insight console, navigate to: Settings - Inventory - Data Insight Servers - <Management Server> - Advanced Settings
  2. Edit the Set custom properties section.
  3. Set the following values:
    1. Property name = report.max.memory.output
    2. Property value = 4096
  4. Click the Save button.
  5. Execute the report once more

The default value for report.max.memory.output is 2 GB which may not be sufficient for reports containing a large data set.

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