Compliance Accelerator and Discovery Accelerator searches time out.

Article: 100013299
Last Published: 2020-09-25
Ratings: 0 0
Product(s): Enterprise Vault

Problem

Compliance Accelerator (CA) and Discovery Accelerator (DA) searches against 64-bit indexes time out immediately.  Browser searches against the same index volumes still work correctly.

 

Error Message

The CA and DA client will return the following error in the information field of the Search Results pane:

The search timed out.  (0x80041c71)

The Enterprise Vault server running the indexing service that is handling the searched indexes generate this event id:

Log Name:      Symantec Enterprise Vault
Source:        Enterprise Vault
Event ID:      41315
Task Category: Index Query Server
Level:         Warning
Description:
A search failed with error "Search engine timeout".

Archive: Journal Archive
Archive ID: 1234ABCDEFG12345ABCDEF1110000EVault
Index volume ID: 1234
Maximum results: 50000
Timeout (seconds): 14400
Sort order: snum

V-437-41315

Cause

Stale, missing or improperly formatted synchronization data from the 64-bit indexes is not returned quickly enough to the search engine, causing the search to time out.

 

Solution

1. Open the Compliance Accelerator or Discovery Accelerator client.

2. Find the index volumes that timed out:
     a. Select the Cases tab.
     b. Select the case with the failed search from the list on the left.
     c. Select the Searches tab.
     d. Select the search that failed.
     e. Under the Search Details section, select the down arrow in the Show drop-down list.
     f. Select Top 2000 archive indexes by hits.
     g. Select Information from the column headers to sort the results.
     h. Review the Information column for any that state:
          The search timed out.  (0x80041c71)
     i. Make note of the Index Volume ID for each.

3. Run this query in SQL against the EnterpriseVaultDirectory database (Note: save the results for step 4 part l):
SELECT IndexVolumeIdentity, FirstItemSequenceNumber, HighestItemSequenceNumber
FROM IndexVolume
WHERE IndexVolumeIdentity IN (XXX, XXX)
; --replace XXX with the 'Index Volume ID' from Compliance Accelerator or Discovery Accelerator

4. Create a Synchronize task for the volumes that timed out:
     a. Open the Vault Admin Console.
     b. Expand the Directory folder.
     c. Expand the Site folder.
     d. Select Indexing'
     e. Select Manage Indexes.
     f. Select Synchronize.
     g. Select Next.
     h. Select Add.
     i. Remove any check marks from Attributes and check only Online.
     j. Click Search.
     k. Select Range in the Search Results columns.
     l. The Range column shows the FirstItemSequenceNumber - HighestItemSequenceNumber for a given index.  Review the Range column for the indexes that were found in the SQL query from step 3.
     m. Select each matching index.
     n. Click Add.
     o. Repeat steps m and n until all indexes have been added.
     p. Click OK.
     q. Click Next.
     r. Use the default name for the task and Click Next.
     t. Click Create Task.
     u. Click Monitor Tasks.

5.  Start the Synchronize task:
Note:  If the task status is already Processing, skip to step 6.
     a. Minimize Monitor Indexing Tasks pane.
     b. In the Vault Admin Console expand the Enterprise Vault Servers folder.
     c. Expand the Server folder.
     d. Select the Tasks folder.
     e. Right-Click Index Administration Task.
     f. Select the Run Now option.
     g. Click Yes
     h. Click OK.

6.  Monitor the Synchronize task:
     a. Restore the Monitor Indexing Tasks pane.
     b. Click Refresh.
     c. All Subtasks should show successful.
         Note: Some may show unsuccessful due to missing items.  Those indexes can still be searched.

7.  Searches in the Pending Acceptance with errors or Failed status with the above error showing in the Info column of any index volume can be resubmitted successfully.

8.  If desired, discard any Failed or Pending Acceptance with errors searches in CA or DAand then abandon them.

9.  Any new searches should complete without receiving the above error in any index volume's Info column.

 

 

Applies To

Enterprise Vault, Discovery Accelerator, and Compliance Accelerator 10.0.0 and higher.

 

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