Event ID's 7206 and 3230 halts processing forcing a reboot of the Enterprise Vault (EV) server.

Article: 100012819
Last Published: 2020-03-18
Ratings: 0 0
Product(s): Enterprise Vault

Problem

When event ID's 7206 and 3230 appear in the event logs the server must be restarted in order to continue processing and retrievals. This issue can affect other processes such as Journaling, PST migrations, retrievals, and mailbox archiving.

Error Message

The Enterprise Vault event logs will show the following errors:

Type :                Error
Event :                7206
Source :                Enterprise Vault
Category :        Archive Task
Computer :        EV1.symc.com
Description:

A locking error has occurred in CEVMAPILieModeLock : 0x102
Internal reference: STWL Write Mutex CMAPISession::CreateMapiSession

 

V-437-7206

Type :                Error
Event :                3230
Source :                Enterprise Vault
Category :        Archive Task
Computer :        EV1.symc.com
Description:
Could not create a new MAPI session on Exchange server 'EXSRV01'.
The most likely cause is a connection issue that is causing excessive delays in the task. This can often be recovered by restarting the MAPI related tasks.

 
Internal References:
Unable to get exclusive access to the MAPI thread pool.
Mutex name: Lie mode lock
Reason: Last lock holder: Process <6832> <ArchiveTask> Thread <11760>
 
V-437-3230
 

NOTE: It is very important to note the Reason from event ID 3230 as it indicates the Process and Thread that is the root cause. Generally, the event ID 3230 will be generated long after the root cause of the issue occurs. Therefore it is necessary to have Dtrace turned on at the time the ArchiveTask process is started until the event ID is generated.

Dtrace of the archive task shows the following:

NOTE: The Dtrace shows an issue in the {CONFIGUREMSGSERVICEATTEMPT.EN_US} function.

4423        17:43:59.444         [6832]        (ArchiveTask)        <11760>        EV:L        {CONFIGUREMSGSERVICEATTEMPT.EN_US} (Entry)

4424        17:43:59.444         [6832]        (ArchiveTask)        <11760>        EV:L        {ConfigureMsgServiceAttempt:#264} Trying ConfigureMsgService using PR_PROFILE_UNRESOLVED_SERVER [EXSRV01], attempt [1] of [5]

Cause

The issue is caused when using the Closest GC registry key in combination with an Exchange 2010 Client Access Server (CAS) and EV 10 SP4. Microsoft recommends not to use the Closest GC key with an Exchange 2010 (CAS).

 

Solution

To resolve the issue remove the Closest GC Registry key from the registry. Next stop the Enterprise Vault services. Then remove all Outlook profiles. Restart the Enterprise Vault services.

The Closest GC registry key is located on the EV server at HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider.

 

Applies To

This issue has been observed in Enterprise Vault 10 SP4 CHF2 connecting through an Exchange 2010 Client Access Server.

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