[#41049] Error during term expansion. [#90056] The expansion of [ ] yielded too many results (max [100,000]) Clearwell eDiscovery Platform
Problem
Performing a search in Veritas Clearwell eDiscovery displays an error in the results pane.
Error Message
[#41049] Error during term expansion. [#90056] The expansion of [ <part of search query>] yielded too many results (max [100,000])
Cause
In the query string is a wildcard that creates over the set limit of terms when expanded across the document base being searched against.
Solution
Option #1. Alter the search query to decrease the number of terms produced from the wildcard(s).
Option #2. Change the system property (esa.textengine.expander.maxresults) to temporarily increase the limit.
Note: It is essential that if the property change is made, it must be changed back post-search to ensure that other searches do not inadvertently consume excess processing power.
To change the property>>
- Log in to Veritas Clearwell eDiscovery as a user with system administrator privileges
- Click System
- Click Support Features
- Select Property Browser from the Choose a Support Feature
- Select System from the Select the case (or system) option
- Enter esa.textengine.expander.maxresults in the Pattern to match option
- Click Submit
- It will display esa.textengine.expander.maxresults = <current value> If it has been changed
- Remove esa.textengine.expander.maxresults from Pattern to match
- Enter esa.textengine.expander.maxresults in Name of property to change
- Enter <New Value> eg. 200,000 in New value (leave blank to remove) .
- Check the Confirm change.Are you sure? option
- Click Submit
- The new value of esa.textengine.expander.maxresults will be displayed.
- Services will now need to be restarted, ensure all users are logged out and restart using option 3, then option 4 on the Clearwell Utility on the Appliance.
- Run the search
- Modify the value until the search completes, then remove the value and return to the default (currently 100,000) by leaving New value (leave blank to remove) blank when setting the value.
Applies To
Veritas Clearwell eDiscovery 6.6 to 7.1.2