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PCI Plugin load issue on NetBackup Appliances (article 100044974)
Abstract
Description
Problem
On a NetBackup Appliance v3.1.2, the collector service aggregates data collected by different plugins in order to facilitate Veritas AutoSupport. If the collector service is down or not running then the command used to bring this service back up and running is systemctl restart as-collector
.
When this command is manually run by the Veritas Support team to fix any issue on a customer’s appliance it turns out that the collector service doesn’t load one plugin called PCI plugin which is responsible for collecting information regarding the PCI cards present on the appliance. As a result, when a customer uses the CLISH command Monitor > Hardware ShowHealth Appliance PCI
there wasn’t any PCI information being shown even if the PCI cards are present on the appliance.
Error Message
On CLISH, an empty table will be seen when Monitor > Hardware ShowHealth Appliance PCI
is run.
Problem
On a NetBackup Appliance v3.1.2, the collector service aggregates data collected by different plugins in order to facilitate Veritas AutoSupport. If the collector service is down or not running then the command used to bring this service back up and running is systemctl restart as-collector
.
When this command is manually run by the Veritas Support team to fix any issue on a customer’s appliance it turns out that the collector service doesn’t load one plugin called PCI plugin which is responsible for collecting information regarding the PCI cards present on the appliance. As a result, when a customer uses the CLISH command Monitor > Hardware ShowHealth Appliance PCI
there wasn’t any PCI information being shown even if the PCI cards are present on the appliance.
Error Message
On CLISH, an empty table will be seen when Monitor > Hardware ShowHealth Appliance PCI
is run.
The following messages can be seen in /log/autosupport/collector.log when systemctl start as-collector
is run manually in order to start the collector service.
Cause
Failure to load the proper AutoSupport Client Plugin for PCI data collection due to an incorrectly defined path.
Solution
Emergency Engineering Binaries (EEBs) are available to fix this vulnerability on the following releases of the NetBackup appliances:
- 3.1.1
- 3.1.2
Apply the appropriate EEB for your version.
Pre-requisites:
Before installing the EEB please note the following:
- To avoid an EEB installation failure you must stop all the Netbackup jobs before installing the EEB.
The EEB provided fixes the issue by correctly loading the necessary AutoSupport Client Plugin for PCI data collection.
Steps to Install the EEB on an Appliance Using CLISH
To download and install the EEB on an appliance (either configured or not configured):
- Log in to the NetBackup Appliance Shell Menu and navigate to
Main_Menu > Manage > Software
- Run the command
Share Open
- Mount the share folder on the host to where downloaded the EEB:
/inst/patch/incoming
- Copy the EEB to the mounted share folder.
- Log in to the appliance shell menu and run the command:
Manage > Software > Share Close
- To list the EEB, run the command:
Manage > Software > List downloaded
- Run the following command to install the listed EEB:
- For NBA 3.1.1:
Install NBAPP_EEB_ET3969634-3.1.1.0-1.x86_64.rpm
- For NBA 3.1.2:
Install NBAPP_EEB_ET3971541-3.1.2.0-1.x86_64.rpm
NOTE: The EEB can also be installed using Appliance Management (AMS).
Applies to the following product releases
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