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NetBackup 8.0 / 8.1 HotFix - Browse and Restore Issues for Exchange 2016 CU5 (article 100034088)

HotFix

Abstract

NetBackup GRT Restore Browse and Restore Issues for Exchange 2016 CU5 and later updates

Description

When Cumulative Update 5 (CU5) and later updates are applied to Exchange 2016, NetBackup is no longer able to restore individual items from a GRT (Granular Recovery Technology) based backup of Exchange 2016.


Error Message

When browsing for GRT restore of Exchange 2016 CU5 and later, the NetBackup Java Backup Archive and Restore (BAR) GUI displays the error "no entity was found".  When using the Windows BAR GUI the error displayed is "Unable to obtain list of files using specified search criteria".


Java Backup Archive and Restore GUI:

Error in Java BAR GUI


Windows Backup Archive and Restore GUI:

Error in Windows BAR GUI


Additional issues:

The BAR GUI displays a public folder mailbox under every database rather than displaying it under only the database to which it belongs.


The BAR GUI shows some system mailboxes. It is not appropriate to restore contents of a system mailbox.


The originally reported issues with GRT browse, including display issues with public folders and system mailboxes were fixed in NetBackup 8.1 and by EEBs for NetBackup 8.0. The following additional issues have been found and are fixed in newer EEBs for NetBackup 8.0 and 8.1.


GRT browse may take a very long time so that it is difficult or impossible to use. The ncflbc log may contain one or more entries reporting an "ExchDbProv check failure" followed by a dump of a portion of the Exchange database.


A message that originally contained non-English text may be unreadable after GRT restore. The text may look like what you would get if you were to interpret UTF-8 multiple-byte characters as so many single-byte ANSI characters.


The original "Cc" recipient list for a message may be placed in the "To" list on a restored message.

 

Cause

The Cumulative Update 5 and later updates for Exchange 2016, released by Microsoft, made significant changes to the Mailbox Database structure.  

Read me

Veritas Technologies LLC has acknowledged that the above-mentioned issues (Etrack 3923207,3925878) are present in the current version(s) listed under the Product(s) Section of this article. Veritas Technologies LLC is committed to product quality and satisfied customers. This issue was currently scheduled to be addressed in the next version of the product.



Workaround:

For NetBackup 8.0 and 8.1, download and apply the hotfix attached to this article

An Emergency Engineering Binary (EEB) bundle containing a fix for the GRT browse issues is available for NetBackup 7.7.3 by contacting Veritas technical support, referencing this document ID and Etrack 3924964.

After installing the hotfix or EEB, you can browse and restore mail items from backups taken before (or after) installing the EEB.  The display issues with respect to public folder mailboxes and system mailboxes are resolved only in new backups taken with the EEB in place. The GRT browse issues are fixed in NetBackup 8.1.1.

The issues with non-English text and the recipient list are resolved with the EEBs for NetBackup 8.0 and 8.1. There do not presently exist EEBs for these issues for NetBackup 7.7.3 or 8.1.1.


If restoring individual items is important to you and you do not apply the hotfix or EEB, the alternative workaround to restore individual items is to restore to a recovery database and use the tools in Exchange 2016 to recover the items.

EEB information:

Bug ID: 3925877 for NetBackup 8.1, 3923206 plus 3945631 for NetBackp 8.0.

Installation Location: Exchange mailbox server

Installation Instructions: Please follow the EEB installer instructions available in the linked Related Article.


Package Contents:

eebinstaller.3923206.1.AMD64.exe             Windows x64 Installation


Checksums:

194522399 1208832 AMD64/ExchDbProv.dll

1718978902 904192 AMD64/libfi_vss_writer.dll


Recommended service state:  Ensure no Exchange backup or restore jobs are running while installing these binaries.


Recommended service state:  Ensure no Exchange backup or restore jobs are running while installing this binary.

Update files

File name Description Version Platform Size

Applies to the following product releases