Problem
For Veritas Cluster Server on Windows, there can be instances when the SG status does not match with the status of its resources.
In such a situation, the status of the resources in the SG will show as Offline but the status of the SG shows as Online.
Checking the status of the resources from Command Line Interface (CLI) confirms the resources are online, but the VCS Java Console fails to update their correct status.
Error Message
There are no error messages seen.
The VCS Java Console is unable to update the correct status of the resources.
As seen in the below instance, the status of the SG:Testing_SG is Online, however all its resources are showing as Offline.

When checked from CLI, the resources are confirmed to be in the Online state.

Cause
The issue is observed when the hostname provided for the SystemList attribute in the main.cf contains one or more letters in lowercase.
The VCS Java console fails to interpret the hostname when added in lowercase.
NOTE: This issue is independent of the version of Windows OS, VCS Java Console and Infoscale.
Solution
This issue is presently under investigation by our Engineering Team. Depending on the results of this investigation, it may be addressed through a patch or hotfix in current or future software releases. However, this specific issue is not currently scheduled for inclusion in any upcoming release. If this issue has a significant business impact on your continued use of the product, please contact your Sales representative or the Sales team to discuss your concerns.
As a workaround:
a) Update the SystemList attribute directly from the VCS Java Console by highlighting the SG name -> Properties Tab on the right pane -> Show all Attributes -> SystemList

NOTE: Entering the hostname in lowercase from the VCS Java Console, the Console will auto-update it to Uppercase when saving the cluster configuration.
b) When using scripts or any automation methods to modify SG(s) in VCS, ensure to provide the Hostname for the SystemList attribute in Uppercase only.
IMPORTANT: The above workaround steps are applicable even if the actual hostname is genuinely in lowercase.