Event ID 4274 and 4273 regarding EVUsageAnalyzerService.exe are seen in the EV application log from Admin Service every time it starts after installing the EV 15.2.1 Release Update.
Problem
After installing the Enterprise Vault (EV) 15.2.1 Release Update, the following warnings and errors are observed in the Enterprise Vault application log under the Admin Service. These events (ID 4274 and 4273) appear each time the Admin Service starts.
As a result, Usage Analyzer reports fail to generate.
Error Message
Log Name: Arctera Enterprise Vault
Source: Enterprise Vault
Event ID: 4274
Task Category: Admin Service
Level: Warning
Description:
UsageAnalyzer\EVUsageAnalyzerService.exe (Attempt: 1) - Restarting failed process
Exit Code: <0xe0434352>
The process has failed abnormally and will be restarted automatically
Log Name: Arctera Enterprise Vault
Source: Enterprise Vault
Event ID: 4273
Task Category: Admin Service
Level: Error
Description:
UsageAnalyzer\EVUsageAnalyzerService.exe (Attempt: 3) - Process failed
Exit Code: <0xe0434352>
The process has failed abnormally and will not be restarted. Either the process has exceeded its restart count or automatic restart is disabled. The process can be restarted by stopping and restarting the Admin Service
In the Windows Application event log, this corresponding event is seen:
Log Name: Application
Source: Application Error
Event ID: 1000
Task Category: (100)
Level: Error
Description:
Faulting application name: EVUsageAnalyzerService.exe, version: 2.2.0.44, time stamp: 0x68395b24
Faulting module name: KERNELBASE.dll, version: 10.0.20348.3932, time stamp: 0x4c7b412e
Exception code: 0xe0434352
Fault offset: 0x000000000003f46c
Faulting process id: 0x34d8
Faulting application start time: 0x01dc44ea63c711e3
Faulting application path: C:\Program Files (x86)\Enterprise Vault\UsageAnalyzer\EVUsageAnalyzerService.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: f2608f21-93e9-4d32-90f3-e266a69c843e
Faulting package full name:
Faulting package-relative application ID:
Cause
This issue is caused by a product defect introduced in the Enterprise Vault 15.2.1 Release Update. The EVUsageAnalyzerService.exe process fails due to a conflict involving the KVS.EnterpriseVault.Runtime.dll library.
Workaround
To resolve the issue, manually replace the affected DLL file using the steps below:
Open PowerShell as an Administrator.
Run the following command:
$installdir = (Get-ItemProperty "hklm:\\Software\Wow6432node\KVS\Enterprise Vault\Install" InstallPath).InstallPath ; Copy-Item -Path "$installdir\Installed Hotfixes\15.2.0\15.2.1.1399\Backup\UsageAnalyzer\KVS.EnterpriseVault.Runtime.dll" -Destination "$installdir\UsageAnalyzer\"
Restart the Enterprise Vault Admin Service.
After performing these steps, the EVUsageAnalyzerService.exe should start successfully, and Usage Analyzer reports will resume normal generation.
Solution
This issue is presently under investigation by our Engineering Team. Depending on the results of this investigation, it may be addressed through a patch or hotfix in current or future software releases. However, this specific issue is not currently scheduled for inclusion in any upcoming release. If this issue has a significant business impact on your continued use of the product, please contact your Sales representative or the Sales team to discuss your concerns.
Note: Customers experiencing this issue are encouraged to contact Arctera Technical Support as data is still being collected to assist in resolving this issue.