Transaction logs do not truncate during a VMWare Exchange virtual machine backup.

Article: 100074677
Last Published: 2025-12-05
Ratings: 0 0
Product(s): Backup Exec

Problem

Transaction logs do not truncate during a VMWare Exchange virtual machine backup.

Error Message

Event Logs shows :

Log Name:      Application
Source:        MSExchangeRepl
Date:          
Event ID:      2047
Task Category: Exchange VSS Writer
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      exchange-server.Domain.local
Description:
The Microsoft Exchange Replication service VSS Writer instance 2be9694d-e008-485c-8fcd-2737c7472059 has successfully completed a backup of database 'DatabaseName'. No log files were truncated for this database because the backup type was a copy backup or a differential backup.

Cause

The backup is full but somehow gets changed to copy backup and hence the logs are not truncated. The Issue is seen with Exchange virtual machine (hosted on VMWare) backup. This problem is not seen with agent-based backup for the Exchange Virtual machine.

Solution

Workaround:

Perform Agent-based backup until the VM-based backup of exchange issue is fixed.
 

A supported hotfix has been made available for this issue. Please contact  Technical Support to obtain this fix. This hotfix has not yet gone through any extensive Q&A testing. Consequently, if you are not adversely affected by this problem and have a satisfactory temporary workaround in place, we recommend that you wait for the public release of this hotfix.

The Product Engineering Team currently plans to address this issue by way of a patch or hotfix to the current version of the software. Please note that we as a company reserve the right to remove any fix from the targeted release if it does not pass quality assurance tests. Our plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.

Please contact your Sales representative or the Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.


 
Note: Customers experiencing this issue are encouraged to contact Veritas Technical Support as data is still being collected to assist in resolving this issue.

References

Etrack : 4189488

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