Problem
Classification of some items fails with Event ID: 29118
Error Message
The Event logs will show the following:
Event ID: 29118 Classification Error.
Reason: Failed to classify item content. (0xc0047196)
Error : SERVER_ERROR|Description : Internal Server Error
Http status code : InternalServerError [500]
Http status message : Server Error
Saveset Id: 202506159997809~202506151429110000~Z~90EEE626D96C8B70A50F8E18CA76C138
Vault Id: 1302F519EB786484AABEC24A7EF0C34481110000SE158060.ev.local
Index Sequence Number: 29597443
The VIC log will show the following:
2025-06-16T14:09:19.802-04:00 ERROR {vic:9196} efe5268ed3224438a4000f71144bb2eb [pool-2-thread-201 - POST /vic/api/v1/classification/classify] [ResourceExceptionMapper] Internal Server Error (500): Internal Server Error
org.apache.commons.lang3.exception.ContextedRuntimeException: Classify failed
Exception Context:
[1:tenantId=_Default]
[2:documentName=F:\EVVaultCache\Classification\EV$C00324FAC2B03AC40135A28C1C310D11~0662F16CVC.txt]
[3:policyIds=[]]
Cause
This issue is due to a defect in the product. Where a policy that includes a proximity condition will fail with a NullPointerException.
Solution
Work Around: This issue can be worked around by either disabling the policy in question or removing the proximity condition in the policy.
Note:
- Disabling the policy in question means that no messages will be classified according to the policy.
- Removing the proximity condition from the policy will only allow messages to be evaluated by the rest of the policy conditions.
- Before using the workaround, review the consequences of doing so with those who will be reviewing the messages.
Solution:
There are no plans to address this issue by way of a patch or hotfix in earlier versions of the software at the present time. However, the issue has been addressed in the revision of the product specified at the end of this article.
Please contact your Sales representative or the Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.
This issue is fixed in the following release(s), available in the Download Center at https://www.veritas.com/support:
- Enterprise Vault 15.1.1
- Enterprise Vault 15.2
Recommend upgrading to these versions or later.