Analysis & Review page hangs up when loading too many documents in Details View

Article: 100074485
Last Published: 2025-06-13
Ratings: 0 0
Product(s): eDiscovery Platform

Problem

When in Analysis & Review tab and selecting Details View with 100 documents to display, the page can be slow to load and even get hung up trying to load all the details.  Each item will have a status circle going around meaning it is still loading the data for that item.  If the top few items load quickly, it is easy to believe the data is fully loaded.  When data is being loaded, all other controls are disabled.  This gives the impression that the page is hung up and not responding.  If the links, tabs, and button controls are not responsive, scroll down the page and any data still loading will have the status circle showing that these items are still being loaded.  It is important to know this behavior.  A couple of ways to speed this page up is to show fewer items per page or use the snippet view.  This is normal behavior.

However, there are times when the data load really does get hung up and the circles will never stop turning.  And because all controls are disabled until the data load is complete, the page is now non responsive and therefore inoperable.  The only option in this condition is to shorten the address in the address bar. This will cause eDiscovery Platform (eDP) to reload back to the dashboard or you can close and open a new browser window and start over.

Error Message

There are no error messages.  In Figure 1 below, 1-5 show the settings that cause more data to load per page, which can lead to the issue.  #6 shows the circle, meaning that this item is still loading.  In Figure 1, the user selected (1) Details View, (2) 100 items to display per page, (3) Document Type filter, (4) Display Emails only, and then (5) selected the Apply button.

Figure 1 (The image below is from an Arctera lab.  All data shown is fictitious):

Cause

Meta data is indexed and loaded fast from the indexing engine.  All other data is retrieved from the source files.  The source must be accessible or else URN errors will be displayed for items not retrievable.  The issue occurs with too many network calls all at once.

Solution

Work Around:
Choose less data to be displayed.  This can be done by displaying data in Snippet View or by reducing the number of items per page to be displayed.

This is slated to be fixed in eDP version 10.3.3

There are currently no plans to address this issue through a patch or hotfix in the current or previous versions of the software. However, it is scheduled to be resolved in the next major product revision. Please note that the product engineering team reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests. Our plans are subject to change, and any actions you take based on this information, or your reliance on it, are at your own risk

References

JIRA : CFT-7060

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