Active Directory scan fails with user/passwd missing

Article: 100074482
Last Published: 2025-06-12
Ratings: 1 0
Product(s): Data Insight

Problem

Active Directory scan fails with a message that the User/Passwd is missing.

This usually occurs after adding in a storage device with a large number of users (SharePoint Online, OneDrive, etc.).

Error Message

adcli.log:

2025-05-29 03:00:40 INFO: V-378-1304-757: #{15316} [mx_ad_list_domains: 473] Not connecting to <DOMAIN> since user/passwd missing

commd0.0.log:

2025-05-29 03:06:03 INFO:    #{58} [ADScanJob.runDirectoryScan] AD scan ended (exit: 32768)
2025-05-29 03:06:03 WARNING: #{58} [ADScanJob.runDirectoryScan] [ERR] Java heap space

cli0.0.log:

2025-05-29 03:00:39 SEVERE:  #{1} [ConfigUtils.main] Command failed
java.lang.OutOfMemoryError: Java heap space
    at java.util.Arrays.copyOfRange(Arrays.java:3664)
    at java.lang.String.<init>(String.java:207)
    at java.lang.String.substring(String.java:1969)
    at java.lang.String.split(String.java:2353)
    at java.lang.String.split(String.java:2422)
    at com.symc.matrix.util.ConfigUtils.getMSUs(ConfigUtils.java:1530)
    at com.symc.matrix.util.ConfigUtils.getMSUs(ConfigUtils.java:1444)
    at com.symc.matrix.util.ConfigUtils.getSiteColls(ConfigUtils.java:1413)
    at com.symc.matrix.util.MapperUtils.populateCache(MapperUtils.java:1270)
    at com.symc.matrix.util.MapperUtils.init(MapperUtils.java:112)
    at com.symc.matrix.util.MapperUtils.getSingleton(MapperUtils.java:95)
    at com.symc.matrix.util.ConfigUtils.isFIPSCompliant(ConfigUtils.java:18194)
    at com.symc.matrix.util.ConfigUtils.get(ConfigUtils.java:15306)
    at com.symc.matrix.util.ConfigUtils.main(ConfigUtils.java:14185)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:65)
    at com.exe4j.runtime.WinLauncher.main(WinLauncher.java:101)
    at com.install4j.runtime.launcher.WinLauncher.main(WinLauncher.java:26)

Cause

The cli process doesn't have enough memory assigned to enumerate all of the users that are discovered from the domain and configured storage devices.

Solution

To increase the memory allocated to the cli process perform the following steps:

  1. On the Management Server, edit the <INSTALLDIR>\Program Files\DataInsight\bin\configcli.vmoptions file with a text editor.
  2. Change the default value of -Xmx100m to -Xmx1024m and save the file.
  3. Restart the DataInsightConfig and DataInsightComm services
  4. Start the Active Directory Scan

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