NetBackup server unable to reach NBSM due to proxy configuration on the NetBackup server.

Article: 100074410
Last Published: 2025-06-03
Ratings: 0 0
Product(s): Appliances, NetBackup & Alta Data Protection

Problem

NetBackup (NBU) attempted to connect to NetBackup Snapshot Manager (NBSM) through a proxy server, which is not a supported configuration.

Observed Behavior:

  • The NBSM status in the NetBackup console appears as Failed.
  • No cloud providers are displayed under the Providers tab.
  • NBSM becomes non-operational.

Error Message

Log location:  /usr/openv/logs/nbemm


02/24/2025 16:45:02.137 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CP: == Info: Trying 10.xxx.xxx.xx:Port...
02/24/2025 16:45:02.137 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CurlHttpClient: After NB_curl_multi_perform: mReadyRes = 0, mStillRunning = 1
02/24/2025 16:45:02.167 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CP: == Info: Connected to (nil) (IP) port PORT (#1)
02/24/2025 16:45:02.167 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CP: == Info: ALPN: offers http/1.1
02/24/2025 16:45:02.167 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CP: == Info: Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
02/24/2025 16:45:02.170 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CP: == Info: successfully set certificate verify locations:
02/24/2025 16:45:02.170 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CP: == Info: CAfile: /etc/pki/tls/certs/ca-bundle.crt
02/24/2025 16:45:02.170 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CP: == Info: CApath: none
02/24/2025 16:45:02.170 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CP: == Info: TLSv1.2 (OUT), TLS header, Certificate Status (22):
02/24/2025 16:45:02.170 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CP: => Send SSL data, 0000000005 bytes (0x00000005)
02/24/2025 16:45:02.171 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CP: => Send SSL data, 0000000512 bytes (0x00000200)
02/24/2025 16:45:02.210 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CP: == Info: OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to proxy_server:port
02/24/2025 16:45:02.210 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CP: == Info: Closing connection 1
02/24/2025 16:45:02.210 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CurlHttpClient: CurlHttpClient::processCompletedEasyHandle: STS error: 2060001, cURL error: 35, multi cURL error: 0, HTTP return value: 0
02/24/2025 16:45:02.211 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CurlHttpClient: CurlHttpClient::processCompletedEasyHandle: Job not succeeded, going for retry..
02/24/2025 16:45:02.211 [Debug] NB 51216 libraries 137 PID:2680 TID:140620299466496 File ID:111 [No context] 1 [CloudPointManager] CPResiliency: CPResiliency::getRetry...

Cause

A proxy was configured on the NetBackup server, which caused all NetBackup services (including communications with NBSM) to route through the proxy. Since the NBSM server was not in the allowed-list  in the proxy configuration, the connection attempt failed.

Solution

Perform one of the solutions below:


1: Ensure that NBU connects to NBSM directly and bypasses the proxy by performing the following:

  • Add the NBSM FQDN or IP address to the no_proxy environment variable.

  • Update the proxy configuration in the appropriate shell profile (e.g., .bashrc):

    • export no_proxy=your_nbsm_host

2: Add the NBSM server to the allowed list on the proxy server.

Note: Either add the NBSM to the allowed-list in the proxy settings, or bypass the proxy for it.

 

References

Etrack : 4198350

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