A Merge1 importer fails to send any items to an EWS target: "All mailboxes are full. There is no active mailbox connection."

Article: 100074340
Last Published: 2025-05-14
Ratings: 0 0
Product(s): Merge1

Problem

An importer sending messages to an EWS target fails with an "All mailboxes are full" error. However, the mailbox is not full.

Error Message

The importer log shows:

2025-05-14 11:01:23,872 [14] INFO  Globanet.Ews.Api - Impersonating for 'Target Mailbox'.
2025-05-14 11:01:25,731 [14] WARN  MailboxConnectionPool - Failed to create 'Target Mailbox' mailbox connection instance. Error: No mailbox with such guid (ErrorNonExistentMailbox)..
2025-05-14 11:01:25,757 [14] WARN  MailboxConnection - Could not establish a connection with the 'Target Mailbox' mailbox.
2025-05-14 11:01:25,789 [14] WARN  MailboxConnectionPool - All mailboxes are full.
2025-05-14 11:01:25,804 [14] WARN  Merge1.Targets.EwsTarget.EwsTarget - Message #70268508 sending failed: All mailboxes are full. There is no active mailbox connection.. Target permanent error occurred. No need to retry with another connection.

Cause

The mailbox full error is a generic error.  Looking in the log, the error message Failed to create 'Target Mailbox' mailbox connection instance. Error: No mailbox with such guid (ErrorNonExistentMailbox).. is seen.  The EWS connection uses the mailbox of the Merge1 service account.  The service account mailbox needs to be in an Exchange on-premises database and not in Exchange Online.

Solution

Migrate the Merge1 service account mailbox from Exchange Online back to Exchange on premises.

Was this content helpful?