IT Analytics - Unable to determine patch level of Veritas NetBackup running on NBPRIMARY, due to: null

Article: 100071366
Last Published: 2025-10-06
Ratings: 0 0
Product(s): NetBackup IT Analytics, NetBackup

Problem

After configuring the IT Analytics - Data Collector policy for Veritas NetBackup and clicking on Test Connection, the test fails with an error.
 

Error Message

Error occurred while executing NetBackup command. Error : Unable to determine patch level of Veritas NetBackup running on NB_primary_name, due to: null
 

Cause

 The Backup Software Location on the NetBackup Primary Server:* path was not set correctly.
 

Solution

Log on to the NetBackup Primary server and verify where NetBackup Primary server biniaries are installed on the file system. In some scenarios, NetBackup was installed on a different drive letter in Windows or on a different partition in Linux.

Log on to the IT Analytics Portal UI and navigate to:
Admin > Data Collection > Collector Administration > Expand the Data Collector where the NetBackup Primary server in question is defined in a policy > Edit the Veritas NetBackup Data Collector Policy > Make sure the Backup Software Location on the NetBackup Primary Server is set, according to the path verified above.

For example: If NetBackup primary server is installed on Windows:


For example: If NetBackup primary server was installed on Linux:


 

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