Problem
If you configure Call Home with an HTTPS proxy server, the Call Home test fails.
Error Message
Cause
AutoSupport does not currently support HTTPS proxy servers for Call Home.
Flex affected versions: 6.0 and earlier
Solution
This issue has two possible solutions:
- Use an HTTP proxy server or no proxy server when you configure Call Home.
- Manually generate the callhome_secret file with the following procedure. If you have a multi-node appliance, you must perform this procedure on both nodes.
Note: This solution is persistent across restarts but not across updates.- Log in to the Flex Appliance Shell and elevate to maintenance mode
- Navigate to the AutoSupport instance with the following command:
docker exec -it autosupport bash - Create a file named bodycon.xml with the following content.
In the <MACAddress> section, replace 00:00:00:00:00 with the MAC address of the host0 interface. You can find the MAC address with the following command:
show hardware-health node component=network
In the <SerialNumber> section, replace VTAS0000000 with the serial number of the appliance node.
<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Body>
<RegistrationGetOwnerDetails xmlns="www.altiris.com">
<DeviceSignature>
<MACAddress>00:00:00:00:00</MACAddress>
<DeviceSecret></DeviceSecret>
<SerialNumber>VTAS0000000</SerialNumber>
<ProductCode>1_0_0_0</ProductCode>
<Model>NBU</Model>
</DeviceSignature>
</RegistrationGetOwnerDetails >
</soap:Body>
</soap:Envelope> - Run the following command:
curl --proxy-insecure --proxy-cacert </path-to-cert.pem> -x <https://proxy-server.com:port> -U <user:password> -X POST -d '@bodycon.xml' https://api.appliance.veritas.com/AutoSupport/MyService.asmx?op=RegistrationGetOwnerDetails -i -H "Content-Type: text/xml; charset=utf-8"
Where </path-to-cert.pem> is the path to the CA certificate, <https://proxy-server.com:port> is the proxy server and port, and <user:password> is the proxy username and password. - In the response, locate the <DeviceSecret> entry and copy the string between the brackets. For example, copy the bold text in the following output:
<DeviceSecret>43545c9bb940f23f9130b79d3cae527e0d447e1751b44b09cdb8f5d8f8cdb84h</DeviceSecret>
- Create a file at the following location:
/usr/openv/runtime_data/callhome_secret - Paste the <DeviceSecret> entry in this file.
- Try to configure Call Home from the Flex Appliance Console.
Note: This issue is currently being considered by Veritas Technologies LLC to be addressed in the next major revision of the product. There are no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. Please note that Veritas Technologies LLC reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability. Veritas’ plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk
